Welcome, Guest. Please login or register.
April 23, 2014, 08:53:27 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Software
| | |-+  Unable to stream music from samba share
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Unable to stream music from samba share  (Read 1712 times)
Gryphraff
Newbie
*
Gender: Male
Posts: 3



View Profile
« on: April 09, 2011, 04:20:42 AM »

I'm currently running Pardus 2011 on a Dell 10v, which is a nice combo. I'd like to stream music from my Windows server - MP3 mostly - to the Pardus machine.

I can create the share just fine, but any attempts to open and play a file over the network gives me a "You can only select local files" error box. Queuing files is ok, as it copies them to the local machine, but that's not an option with a large amount of music. Clementine and a few other music players do this.

I'm guessing this has something to do with the programs in question not being able to handle the smb protocol, whereas Dolphin is designed to do that. Research suggests it has to do with permissions and such, but the information I found didn't really mean a whole lot, other than "Yeah, it does that..."

 Any ideas?
« Last Edit: April 09, 2011, 04:32:27 AM by Gryphraff » Logged

seeking an alternate trout
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #1 on: April 09, 2011, 22:06:58 PM »

Any ideas?
Short answer: NO Wink
Logged
Gryphraff
Newbie
*
Gender: Male
Posts: 3



View Profile
« Reply #2 on: April 13, 2011, 03:19:41 AM »

It looks like I would have to mount the remote share into a local folder to make that happen. I don't understand mounting stuff yet, so that will have to wait...
Logged

seeking an alternate trout
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #3 on: April 13, 2011, 07:39:56 AM »

......I don't understand mounting stuff yet, so that will have to wait...
Try System Settings > Disk Manager.....
May it will the solution.
Logged
dedebekri
Pardus fellow craft
**
Posts: 72


View Profile
« Reply #4 on: April 26, 2011, 14:44:13 PM »

I was wondering the same, finally solved it!  Grin

First make a directory in /mnt;
sudo mkdir /mnt/Mp3

Then mount remote directory to your newly created /mnt/Mp3;
sudo mount -t cifs //192.168.0.XXX/SHARED/DIRECTORY/Mp3 /mnt/Mp3 -o username=YOURUSERNAME,passwd=YOURPASSWORD,noexec

Well, you need to know the IP address as well as username and password on the remote machine. That's it.
Now add your /mnt/Mp3 to Clementine's library and enjoy!...

EDIT: If you'd like to mount the shared directory everytime your machine boots, you need to add it to /etc/fstab list;
sudo nano /etc/fstab

add this to your list;
//192.168.0.XXX/SHARED/DIRECTORY/Mp3 /mnt/Mp3 cifs username=YOURUSERNAME,passwd=YOURPASSWORD,noexec  0 0
« Last Edit: April 26, 2011, 15:18:33 PM by dedebekri » Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!