Welcome, Guest. Please login or register.
April 20, 2014, 02:54:17 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Pardus for beginners
| | |-+  suppress message box
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: suppress message box  (Read 912 times)
Kranthi
Pardus fellow craft
**
Gender: Male
Posts: 102



View Profile WWW
« on: February 04, 2011, 15:42:05 PM »

When I copy files from home to other partitions i get a message saying
"could not change permissions for <path/filename>"
I get this message for each file separately. This is very annoying as i have to keep focus on copying till the whole process is over.
Is there a way to remove such messages or better to show such a message in the end in batch?
Logged

The Cube
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #1 on: February 04, 2011, 21:04:01 PM »

And what are the properties of the other partition ?
Go in Dolphin to the other partition and do a right-click > Properties > Permissions.
What are the values for: Owner:, Others:, User: and Group: Huh?
Have a in the >"How to make your USB-stick/hard disk with vfat/ntfs/ext*/jfs/xfs/reiserfs partition writable"< Wiki for the required value.
Logged
Kranthi
Pardus fellow craft
**
Gender: Male
Posts: 102



View Profile WWW
« Reply #2 on: February 05, 2011, 07:04:58 AM »

Home folder:
                 read          write           exec
user          yes            yes             
Group       yes
others      yes
owner(user)yes           yes
dump partition:
                 read          write           exec
user          yes            yes             
Group        yes            yes             
others             
owner (root)yes          yes
Logged

The Cube
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #3 on: February 05, 2011, 13:09:42 PM »

dump partition:
Is this the partition you want to write your file(s)
Logged
Kranthi
Pardus fellow craft
**
Gender: Male
Posts: 102



View Profile WWW
« Reply #4 on: February 05, 2011, 13:25:21 PM »

yes. The files write both ways.
But when i write files from home partition to dump partition, The message box appears.
the dump partition is ntfs
Home partition is ext4
Logged

The Cube
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #5 on: February 05, 2011, 13:39:53 PM »

the dump partition is ntfs
And how do you mount this partition?
Is it listed in /etc/fstab?
Logged
Kranthi
Pardus fellow craft
**
Gender: Male
Posts: 102



View Profile WWW
« Reply #6 on: February 05, 2011, 14:51:28 PM »

yes it is listed on fstab and is mounted automatically
Logged

The Cube
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #7 on: February 05, 2011, 15:06:47 PM »

Can you post the line from /etc/fstab here?
In this way I can have a look at it.
Logged
Kranthi
Pardus fellow craft
**
Gender: Male
Posts: 102



View Profile WWW
« Reply #8 on: February 05, 2011, 15:19:51 PM »

Cat command on fstab
#
# Created by YALI on Sat Jan 22 21:52:39 2011
#
UUID=7b9eeff3-c214-40e7-876c-0b2d62b84a52 /                       ext4    defaults        1 1
UUID=f816d01f-bfec-4314-af09-7304a6b21506 /home                   ext4    defaults        1 2
UUID=08b7db95-78aa-4cdd-bbe6-50a2a98249e2 swap                    swap    defaults        0 0
tmpfs                   /dev/shm                tmpfs   nodev,nosuid,noexec 0 0
debugfs                 /sys/kernel/debug       debugfs debugfs,defaults 0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
UUID=d9108d8f-4b93-476b-8e59-facadeed0087 /mnt/archive ext4 noatime 0 0
UUID=7C5470DA5470989A /mnt/dump ntfs-3g locale=tr_TR.UTF-8,dmask=007,fmask=117,gid=6 0 0
UUID=c77f4271-b084-42a4-9adc-b9f7ca7aa1e1 /mnt/oldhome ext4 noatime 0 0
UUID=823C04F63C04E74F /mnt/windows ntfs-3g locale=tr_TR.UTF-8,dmask=007,fmask=117,gid=6 0 0
Logged

The Cube
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #9 on: February 05, 2011, 15:57:21 PM »

Nothing wrong with that.
But I see:
dump partition:
                 read          write           exec
user          yes            yes              
Group        yes            yes              
others            
owner (root)yes          yes
To correct the permissions:
Open dump partition in Dolphin.
Go one level up with the "Up" button.
Right-click on the directory "dump" > Root actions > Change Permissions >
Yes in the  "Do you wish to apply..." KDialog screen.
The following entries in Permissions KDialog should be marked (bleu colour):
ALL except the 3 bottom ones with Special:.....
After OK, enter password and restart the computer.
If everything is the problems should be solved now.
« Last Edit: February 05, 2011, 16:07:45 PM by atolboo » Logged
Kranthi
Pardus fellow craft
**
Gender: Male
Posts: 102



View Profile WWW
« Reply #10 on: February 05, 2011, 17:47:50 PM »

but i don't want to give the permissions to everyone.
I don't want to change the permissions as i think that they are proper and secure that way.
I just want to disable that dialog box which says "could not change permissions for <path/Filename>"
Because it is just an information as i cannot do any thing other than click "ok" and only that button is available.
And everytime such a dialog box pops up, the copying process stops till i click "ok".
So i think that it would be better to show that information in a notification using Knotify.
Logged

The Cube
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #11 on: February 06, 2011, 09:38:23 AM »

but i don't want to give the permissions to everyone.
Maybe it's also possible to play with dmask=007,fmask=117 in /etc/fstab Huh?
I never tried this, so it's only a guess.
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!