Welcome, Guest. Please login or register.
April 18, 2014, 11:01:01 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Bugs
| | |-+  [solved] okular won't print .pdf - bad job-sheets value - Pardus 2011
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: [solved] okular won't print .pdf - bad job-sheets value - Pardus 2011  (Read 2028 times)
Pardus Guru
Posts: 841

View Profile
« on: February 15, 2011, 18:49:58 PM »

Hi all,
Just wondering if this bug only effects me.  I am trying to print a receipt I saved as .pdf.  Okular does nothing.  When I run okular from command line, error:
$ okular
okular(1905)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(1905)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(1905)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
lpr: Bad job-sheets value ""!

It is very similar to this bug at launchpad:
I haven't tried the work around posted there as it is for kubuntu.  Anyway, just curious if anyone else had this problem.
Regards, Lisa Marie
« Last Edit: February 16, 2011, 03:33:58 AM by Lisa » Logged
John A
« Reply #1 on: February 15, 2011, 19:56:44 PM »

Its some bug reports of Okular in Bugzilla to:
Pardus Guru
Posts: 841

View Profile
« Reply #2 on: February 16, 2011, 03:50:25 AM »

Thank you, John!  I used Google translator and none of the bugs listed were related to mine.

So, I decided to have a look at this file:
sudo cat /etc/cups/printers.conf
and sure enough, it showed thus:
I decided to try the suggestion from the launchpad by going to system settings>printer configuration>Local Printers>iP3000>Policies>Banner Settings and here is where I wanted to add 'none' to empty fields of Starting Banner: and Ending Banner:  but both fields with drop down arrows were faded and empty of any settings, and trying to type the word 'none' would not work.

My work around: sudo pisi install system-config-printer-gtk, which also installs dependency, notify-python.  I opened terminal, entered: system-config-printer
went to Policies>Banner
and under Starting Banner and Ending Banner, there were the entries, "None", so that made me happy.  I think after this, I clicked on "Apply", but not sure, but went ahead and closed that GUI and went back and checked the file, /etc/cups/printers.conf
and was happy to see it had changed to:
JobSheets None None
I just tested Okular and it printed my receipt with no problems.
Tomorrow I will mention this to Pardus team.  I'm too tired right now from doing too much digging to prepare a spot for the blueberry bushes.  I seem to have come out of hibernation with this recent warm up we have been experiencing.  A good sort of tired  Cheesy
Thanks for the bug links!
Lisa Marie
Edited to add:
I submitted a bug report.
« Last Edit: February 16, 2011, 18:18:04 PM by Lisa » Logged
Pardus Guru
Posts: 841

View Profile
« Reply #3 on: February 18, 2011, 23:03:53 PM »

Hi all,

Gokcen Eraslan fixed this bug, but ignorant me does not understand the instructions on how to test the fix.  I did remove my printer, and then did a sudo pisi up, but confused as to how to test the fix, and I'm too emberrrassed to ask Gokcen for further instructions.  I see a patch, but don't know what to do with it.   Embarrassed   I'm such a newbie tester.
Regards, Lisa Marie

Fire drill over. I figured it out.  PiSi is installing kdeadmin-4.5.5-51-p11-x86_64.pisi that I found in test repos.  Cheesy
« Last Edit: February 18, 2011, 23:41:22 PM by Lisa » Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!