Welcome, Guest. Please login or register.
April 17, 2014, 09:03:28 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  Wireless not powering on
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Wireless not powering on  (Read 1749 times)
Desire
Newbie
*
Posts: 4


View Profile
« on: February 20, 2011, 05:56:29 AM »

I am new to Pardus and I really like it. I have a brand new Lenovo Thinkpad L512 and I have installed several 64-bit distros. Sadly, only the ubuntu-based distros (Kubuntu, Mint) are able to get my wireless working. I don't like the ubuntus very much, which is why I am glad I found Pardus. However, even though Pardus has the right drivers preinstalled  (rtl8192se), it doesn't power on the wireless. I tried "ifconfig wlan0 up" command and I get the "siocsifflags: operation not permitted" error. I am not too experienced with linux so I don't know what to do next. All I need is to power on the wireless and I think I will be good to go. Currently I have Pardus 2011 64-bit. 
Logged
Michiel
Administrator
Pardus Guru
*****
Posts: 799



View Profile
« Reply #1 on: February 20, 2011, 09:13:34 AM »

Perhaps not relevant at all, but perhaps also to basic to easily overlook: did you mark the checkbox in Kaptan when you first configured your wireless connection? You can check that by opening the Network Manager application (GUI) to see whether the checkbox of the connection that you want to use is checked?
Logged

Former Pardus user, now on OpenSUSE 12.2 (KDE)
Desire
Newbie
*
Posts: 4


View Profile
« Reply #2 on: February 21, 2011, 01:31:29 AM »

Both the wired and wireless connections are enabled in NM. Yet the wireless won't power on.
Logged
Desire
Newbie
*
Posts: 4


View Profile
« Reply #3 on: February 21, 2011, 01:34:34 AM »

I must also say that this computer is dual booting with Windows 7, and there is no problem in windows (as expected). Perhaps the important question is how can Kubuntu automatically turn on the wireless and yet Pardus doesn't? Is there a program I am missing in Pardus?
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #4 on: February 21, 2011, 12:23:52 PM »

I am new to Pardus and I really like it.
.
 Currently I have Pardus 2011 64-bit. 
First a from >here<.

And to solve your problem with the automatic wireless connection, open...
System Settings > Network Settings > Network Connections > Wireless tab > select Connection > Edit ....
Is there a mark at "Connect automatically" ?
Maybe you forgot to set this mark when initializing the wireless connection Huh?
Logged
James T
Pardus Master
***
Posts: 155



View Profile
« Reply #5 on: February 21, 2011, 17:58:18 PM »

I must also say that this computer is dual booting with Windows 7, and there is no problem in windows (as expected). Perhaps the important question is how can Kubuntu automatically turn on the wireless and yet Pardus doesn't? Is there a program I am missing in Pardus?

This sounds very much like the problem I have with my laptop,  with Kubuntu and the Chakra live media the wifi toggle hotkey works fine but under Pardus (2011 and 2009.2) it is ignored and the wireless is stuck in the state that it powered up (usually off but occasionally on). This is with a different wireless card & driver (Intel, iwlagn).  I have reported this as bug 15552 (http://bugs.pardus.org.tr/show_bug.cgi?id=15552). My suspicion is that the problem is with the keyboard handling  rather than the wireless or rfkill modules.

To verify that the problem lies with the card switching try the following command in a terminal window:
Code:
rfkill list
I would expect this to tell you that the interface is hard blocked. (You may need to use sudo [i.e. "sudo rfkill list"] to access the low level information I don't remember and I don't have the machine to hand right now).
Logged
Desire
Newbie
*
Posts: 4


View Profile
« Reply #6 on: February 24, 2011, 21:33:29 PM »

All my devices are both hard and soft blocked.

However, I am suspecting that there is a bug in KDE itself that somehow blocks the ability of the system to make the wireless work. Here's why:
1. I installed Salix KDE 13.1, 64-bit. Again, wireless is not working. I tried to install drivers myself (the tar.gz file from Realtek), still no success.
2. I tried openSUSE KDE 11.3, 64-bit, still the same issue.
3. I tried Mandriva One KDE 2010, still no luck
4. Sabayon 5.5 KDE failed as well.
5. Fedora 14 KDE was also disappointing.

Then I decided to install Fedora 14 64-bit GNOME, and as expected, the wireless was down. But, I installed the tar.gz file, and just like that, wireless is up and running. How come Fedora KDE and all other KDE distros failed?

At my workplace there is no wired network so I need wireless. I really want Pardus, but I can't use it at work. Windows 7 is OK, but I'd rather do all my work in linux. So for now I'll be using Fedora 14 Gnome, but I will keep checking to see how Pardus is changing things (but it sounds more like the KDE project itself is to blame for the issues I have)
 
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!