Welcome, Guest. Please login or register.
April 17, 2014, 08:58:01 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Hardware
| | |-+  wireless lost on reboot
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] 2 Go Down Print
Author Topic: wireless lost on reboot  (Read 2962 times)
DavidD
Pardus fellow craft
**
Gender: Male
Posts: 73



View Profile
« on: March 02, 2011, 17:00:36 PM »

I have a Broadcom 4318 that is recognized on installation (light comes on) but is very difficult to configure only because (I should say "apparently because") the network name is not broadcast and I am using encryption. I have to turn encryption off at the router, type in the network name, and then reboot and/or issue several ifconfig/iwconfig commands to get a connection. Then I have to set encryption at the router again, set encryption on the laptop, reboot and/or "iwconfig wlan0 essid ..... key s:....." to get the connection under encryption.

Now here's the real issue: Upon reboot, I can only make it connect again with the last iwconfig command above. I can find no other way to make it reconnect.

What am I missing? I've just installed network-manager-applet, but I cannot find it on the menu or start it via the command line. It is missing in action even though Pisi shows it installed! All my GUI efforts have been with the NM application in the panel, by the way. I'd use WICD in a heartbeat, but it's not available.

I need a "start network" command at bootup, as this bareback routine will not do. Shell script? If so, how to write it and where to put it.

Thanks - and apologies for the impatience. I've been working on it for the last two hours and am worn out and frustrated. Pardus is wonderful in almost all respects. With a few more applications and some way to "start" the wireless network running, it would be beyond great.

David
Logged

"The most tragic pathologies we've experienced in human history result from the catastrophic way we deal with otherness." - D. Gordis
DavidD
Pardus fellow craft
**
Gender: Male
Posts: 73



View Profile
« Reply #1 on: March 03, 2011, 15:20:20 PM »

I changed the configuration of my router to broadcast the SSID -- something I do NOT want to make permanent -- and the connection resumed immediately upon reboot. I've used several of distributions on this laptop. Pardus 2011 is the only one that requires SSID broadcast to reconnect the wireless.

Perhaps I should file a bug report on this issue.

David

Logged

"The most tragic pathologies we've experienced in human history result from the catastrophic way we deal with otherness." - D. Gordis
John A
Guest
« Reply #2 on: March 03, 2011, 18:47:35 PM »

I think you can file a bug report. Good if the Pardus developers be aware of problems.
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #3 on: March 03, 2011, 19:36:12 PM »

You could try a file in /home/your_username/.kde/Autostart (P2011) or /home/your_username/.kde4/Autostart (P2009
Code:
#!/bin/bash
iwconfig wlan0 essid ..... key s:.....
exit 0
This file should be executable in Properties > Permissions.
Logged
DavidD
Pardus fellow craft
**
Gender: Male
Posts: 73



View Profile
« Reply #4 on: March 04, 2011, 04:40:45 AM »

Thanks to both of you!

I will file the bug report ASAP and the script when I return to the house.

By the way, while visiting my brother today I tried two USB wireless dongles, one a Linksys G and the other a RaLink chip on a no name dongle. He could not get the Linksys to work on anything he had tried (Ubuntu, Mint, and I don't know what else). I plugged it into this notebook and it recognized and configured both dongles with no problem. His SSID is broadcast and he has WPA2 security. (I already had configured my Broadcom 4318 for his network, so the way was paved; but still that's about as painless as it gets.
Logged

"The most tragic pathologies we've experienced in human history result from the catastrophic way we deal with otherness." - D. Gordis
DavidD
Pardus fellow craft
**
Gender: Male
Posts: 73



View Profile
« Reply #5 on: March 09, 2011, 03:46:59 AM »

I think you can file a bug report. Good if the Pardus developers be aware of problems.

Bug 17248.

David
Logged

"The most tragic pathologies we've experienced in human history result from the catastrophic way we deal with otherness." - D. Gordis
DavidD
Pardus fellow craft
**
Gender: Male
Posts: 73



View Profile
« Reply #6 on: March 09, 2011, 03:51:34 AM »

You could try a file in /home/your_username/.kde/Autostart (P2011) or /home/your_username/.kde4/Autostart (P2009
Code:
#!/bin/bash
iwconfig wlan0 essid ..... key s:.....
exit 0
This file should be executable in Properties > Permissions.

I'm not skilled at scripting, so the problem may be the connection between the keyboard and the chair  Wink; but I could not get a script to invoke the command successfully. I followed your pattern, double checked the command syntax, placed it (without extension) in the folder you suggested for 2011, made it executable, rebooted, ... nothing happened.
« Last Edit: March 09, 2011, 03:55:16 AM by DavidD » Logged

"The most tragic pathologies we've experienced in human history result from the catastrophic way we deal with otherness." - D. Gordis
DavidD
Pardus fellow craft
**
Gender: Male
Posts: 73



View Profile
« Reply #7 on: June 29, 2011, 05:58:41 AM »

I've just appended this statement to bug #17248 to which I've received no response:

Much to my disappointment, the same issue confronts Pardus 2011.1 Beta. While I don't have to remove security on the router for Pardus to find the hidden wireless network, the connection is lost on reboot as before with Pardus 2011, and the iwconfig wlan0 command is required to re-establish the wireless connection.
Logged

"The most tragic pathologies we've experienced in human history result from the catastrophic way we deal with otherness." - D. Gordis
owiknowi
Guest
« Reply #8 on: June 29, 2011, 12:38:12 PM »

more or less the same troubles here.

summary: april 2011 a default installation of pardus kurumsal 2 on hp dev6-3185ed. could immediately connect to my hidden network (router set to no broadcast essid).

after about a month, running on battery, sudden shutdown due to power drain. after that could no longer connect with the hp dv6 to the hidden network.

remarkable is other linuxes too no longer connect (except mint 11 live dvd who suddenly could yesterday).
w7 had/has no problems connecting (came shipped with the dv6).

connecting to a not hidden network works just fine, but i want mine not broadcasted.
Logged
DavidD
Pardus fellow craft
**
Gender: Male
Posts: 73



View Profile
« Reply #9 on: June 29, 2011, 17:38:38 PM »

Thanks for pointing me to your thread. All my penguins except Pardus 2011 (and now 2011.1) connect to my hidden wireless network from this somewhat elderly HP Compaq V2000 series with the Air Force One wireless hardware (bcm4318). If I un-hide the network, the issue is solved, but, like you, I want to keep it hidden. I realize you are having problems with all but W7, which is mysterious.

Now, a complete surprise to me. The venerable Atolboo suggested to me and now has suggested to you placing a startup script in the Autostart folder inside /home. When I tried it back in March, it did not work. I just tried it again - and this time it worked. The wireless connection to my hidden network was established at boot. As I often quip, the problem back in March may have been "between the keyboard and the chair."

I hope that the script will solve your problem. It nevertheless seems that there is an issue between Pardus and hidden wireless networks. I will soon (probably not today) slip an old Netgear PCI wireless G card into my desktop machine running Pardus to see whether the connection is made to the network using other-than-HP hardware.
« Last Edit: June 29, 2011, 17:56:43 PM by DavidD » Logged

"The most tragic pathologies we've experienced in human history result from the catastrophic way we deal with otherness." - D. Gordis
owiknowi
Guest
« Reply #10 on: June 29, 2011, 18:12:44 PM »

will try atolboo's script a few times more in the next couple of day. so thanks for your information!

btw. other computers with pardus kurumsal 2 (tried asus, compal and samsung) are however able to connect to my hidden network. it even did too out of the box the first time installed on the hp

referring to 'the hitchhikers guide to the galaxy': maybe the syrius cybernetic corporation builds all newer computers nowadays?
if so, we don't have to bother any longer: nothing will ever work again like it did!  Wink
Logged
DavidD
Pardus fellow craft
**
Gender: Male
Posts: 73



View Profile
« Reply #11 on: June 30, 2011, 01:37:31 AM »

I will soon (probably not today) slip an old Netgear PCI wireless G card into my desktop machine running Pardus to see whether the connection is made to the network using other-than-HP hardware.

No joy with the Netgear card, which has an Atheros chipset. I still have to employ the iwconfig wlan0 command. So it's not necessarily an HP issue.
Logged

"The most tragic pathologies we've experienced in human history result from the catastrophic way we deal with otherness." - D. Gordis
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #12 on: June 30, 2011, 16:17:42 PM »

I still have to employ the iwconfig wlan0 command. So it's not necessarily an HP issue.
On my MSI Wind U90X-037EU ( in P2009) I only have to select (=enable) the connection in the Network Manager Applet in Systray to get a fully functional connection after a cold start.
Tested with "ping -c 1 google.com".
Now I have to find a (konsole) command to switch on (in this case) wlan0 Huh?
Logged
DavidD
Pardus fellow craft
**
Gender: Male
Posts: 73



View Profile
« Reply #13 on: June 30, 2011, 22:45:34 PM »

Atolboo,

Merely selecting the applet does nothing. Repeatedly configuring it does nothing. There needs to be a trigger, and in some versions of Network Manager there is the option "Connect to a Hidden Wireless Network" (whose SSID is not being broadcast). That's what I have been looking for.

That's what gets it done in Ubuntu, Mint, and others.

Regardless, I've been working on various changes and now have the connection occurring at boot. I've commented out the "browse" line in /etc/avahi/avahi-daemon.conf [server] section, an item of discussion in the other thread between owiknowi and Lisa. I then removed your bash script that was making the connection at boot. On reboot, the connection was made automatically. So I'm happy about that.

What is driving me crazy now is that I'm unable to shutdown this notebook, perhaps because of all this tinkering. It hangs at "Unmounting filesystems" for many minutes, then stops shutting down after "INIT: no more processes remaining at this runlevel." I have to hold the power switch down until it's off. That's off-topic here, but I'm thinking that I should go back and un-comment the avahi-daemon.conf line and put the bash script back.
« Last Edit: June 30, 2011, 23:01:31 PM by DavidD » Logged

"The most tragic pathologies we've experienced in human history result from the catastrophic way we deal with otherness." - D. Gordis
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #14 on: June 30, 2011, 23:14:07 PM »

I can only try to make it a working system on my MSI Wind U90X-037EU with 3 different wireless devices in P2009.
After this in P2011 and Kurumsal 2 (both have the same Network Manager).
After this I can test this on my main computer with 2 different wireless devices and 3 different Pardus.
Logged
Pages: [1] 2 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!