Welcome, Guest. Please login or register.
April 19, 2014, 04:00:30 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  DNS in 2011
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: DNS in 2011  (Read 3964 times)
Aero9000
Newbie
*
Posts: 14


View Profile
« on: April 02, 2011, 13:40:19 PM »

Hello,

I' ve been using pardus since release 2007. In these older, KDE3, versions, one could easily set the DNS servers via the network applet. You could choose from "automatic" and "manual". In automatic mode the DNS servers were set to some servers in Turkey (I guess, the Pardus DNS servers).

How can I change the DNS server settings in Pardus 2011? There appears to be no such option in the network applet.
Logged
John A
Guest
« Reply #1 on: April 02, 2011, 16:07:23 PM »

I have seen this topic here to:
http://www.wilderssecurity.com/showthread.php?t=286279

Maybe someone here know more about this.
Logged
John A
Guest
« Reply #2 on: April 02, 2011, 16:52:53 PM »

Try to go in the system settings and change there.
See the screenshot.


* networksettings.png (852.28 KB, 1680x1050 - viewed 139 times.)
Logged
dedebekri
Pardus fellow craft
**
Posts: 72


View Profile
« Reply #3 on: April 02, 2011, 17:06:15 PM »

Click network manager icon in the system tray > manage connections > choose your connection and click edit > an options window will open, change method from "automatic (DHCP)" to "only automatic addresses (DHCP)"

Now you will notice that "DNS servers" text box is enabled on the very same window. Now you click " ... " at the end of the text box, and add your favourite DNS servers.

PS: Since I use Pardus in Turkish, some terms may not be the exact equivalents in English.
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #4 on: April 02, 2011, 22:16:48 PM »

I've been trying this all afternoon (and it's such a pretty day outside  Smiley  ), but the nameservers are removed and the default Pardus ones are back in place in /etc/resolv.conf upon reboot.  Doing a search on the problem, it seems an age old problem as DHCP somehow resets them to the defaults when one reboots. 

I'm not a good feedback for this though, as I use dial up (kppp utility) and I'm using the experimental KDE 4.6.1.  I still can't  use network manager as it continues to have 'Wired' grayed out with VPN being the only selection that I can click on.  If I try to change nameservers in kppp and 'disable existing nameservers' , openDNS ones also disappear upon reboot.  Looks like the only answer I found was to edit the resolv.conf file and then change its permissions to make it unchangeable.

And as another problem for another thread, I also cannot use rfkill.  It's installed and executable, but I get the error:

Code:
$ rfkill list
Can't open RFKILL control device: No such file or directory

Time to go outside and pull weeds.  Grin
Lisa Marie
Logged
John A
Guest
« Reply #5 on: April 03, 2011, 10:45:58 AM »

You can try to look in the KDE documentation to:
http://docs.kde.org/stable/en/kdenetwork/kppp/account-dns.html
http://userbase.kde.org/KNetworkManager

I dont know if its any information in Pardus wiki about it.

Its some bug reports here to:
http://bugs.pardus.org.tr/show_bug.cgi?id=10735
http://bugs.pardus.org.tr/show_bug.cgi?id=17248

If search with "network" all this coming up:
http://bugs.pardus.org.tr/buglist.cgi?quicksearch=network

If search with "DNS" this shows:
http://bugs.pardus.org.tr/buglist.cgi?quicksearch=DNS
« Last Edit: April 03, 2011, 10:56:14 AM by John A » Logged
John A
Guest
« Reply #6 on: April 03, 2011, 12:46:37 PM »

I write a own report of this issue here:
Bug 17640

So be free to read and maybe add some comment.
   

Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #7 on: April 03, 2011, 17:10:50 PM »

Hi John A and thank you for all of those links.

An update to what I complained about yesterday...while I was trying to work on all of this, the desktop continued to be sluggish, even though I thought it was back to normal response after last devel update.  I was wrong.  So, I decided to revert back to KDE 4.5.5 desktop but, as there is no History Manager in this Pardus version, I manually tried to reinstall the package.  Obviously I didn't re-install the correct dependencies and Long story short, I broke my system.  I'm good to go now after a fresh reinstall.   Cheesy

Another point that was solved was the grayed out 'Wired' in NetworkManager>Network Connections.  This was purely my fault.  I restarted computer, went into BIOS and enabled LAN.  I keep this disabled as I don't use a LAN/Ethernet/DSL modem as it isn't available here.  Once I enabled it though, upon log in, the NetworkManager applet now showed as an RJ connector and I clicked on it and Wired, VPN, and DSL were now reachable.  Silly me, I thought 'wired' was also for land-line dial up, but it is not.  Obviously not, as there was on place to enter a telephone number.  I felt like 'Duh'!  But I live and learn.  So, with that mystery solved, (Oh how I wish I could create an alternative to Network Manager!-they need some healthy competition).  I am now ready to try again to use altnernative free nameservers.  I was able to do this easily enough last year without them being reset each time on reboot, so something has changed. 

To check what they are after dialing in, I use command:
Code:
nslookup altavista.com

Time to reinstall necessary updates.  Good thing I saved them on my handy Seagate FreeAgent GoFlex drive.  Smiley  I'll look over your links in a bit and if I solve this, I'll certainly let you know.

Update:  The KDE KPPP how to is consice, and that is where I've been having the problem, but it does show how the manually ad nameservers and disable existing ones.  Problem is, that when I click OK, the resolv.conf file is still the same.  Normally, it will append the added servers in resolv.conf file and state next to them, something like, "kppp added".  It's not doing it this time, and I assume it is because of permissions for resolve.conf owned by root, and only root can r/w to it. 

After doing some searching, changing the permissions such as this
is not the way to go about it.
Instead, it appears I  need to figure out how to edit a certain file as is suggested  here
I should be happy with Pardus nameservers, especially after I read things like this


Lisa Marie 
« Last Edit: April 03, 2011, 23:32:30 PM by Lisa » Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #8 on: April 04, 2011, 02:04:11 AM »

Lo and behold.  I just restarted the computer and well, it's as it should be:
Code:
nameserver 4.2.2.4
nameserver 193.140.100.210
nameserver 193.140.100.215
nameserver 4.2.2.5 #kppp temp entry
nameserver 4.2.2.4 #kppp temp entry

Well, sort of.  I again opened KPPP>configure>edit> at DNS tab I added the two bottom nameservers shown above and clicked ok.  I then looked at resolv.conf and it still had the three Pardus nameservers.  So, as root,  I manually edited resolv.conf and added 4.2.2.4 placing at the top of the list and left two of the Pardus nameservers in case they needed to be there just to make things work right.  Saved that file and it worked while I was on line during that session.  I figured it would be reset upon reboot, but it didn't. 

I now understand that KPPP adds any additional nameservers you've added at the next log in when you connect using KPPP, as John A's link showed.   Roll Eyes   It took a while to figure that part out.
Got that sorted. 
Lisa Marie
P.S. Had to come back in here and say, yes, this other nameserver is a lot faster.  I'm really noticing the speed difference on dial up - pages load much quicker.  I'm happy!  I got the nameserver from that link I posted about opendns from abest web dot com.
« Last Edit: April 04, 2011, 17:10:29 PM by Lisa » Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!