Welcome, Guest. Please login or register.
April 19, 2014, 07:44:02 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  General
| |-+  General topics
| | |-+  What applications you want in Pardus 2011?
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: What applications you want in Pardus 2011?  (Read 1213 times)
John A
Guest
« on: April 10, 2011, 17:37:54 PM »

I get some respond from the bug report # 17706


Hi,

I've tried to import some old packages from other Packagers from 2009.2 to
2011. After some time, I tought that enough packages was imported to 2011. As
you said, we see that's not correct. There are lots of packages that should be
imported to 2011. However we lack of Packagers of these packages. Moving
packages is easily, however maintining them is the real problem.

For example Licq. After moving it to 2011, who will maintain it ? What if a new
version appears and I didn't see this new version release coming ?  I currently
have ~300 packages (like other Pardus developers), and believe me It's really
hard to look for all of them. We just have to find a way how to maintain these
packages after moving to 2011.

But I think we all can fix this. With the community itself.  

From now on, I'll think to spend 1-2 hours of my spare time to these packages
(may be other developers could join me too). But I can't do that alone.
Alatalo, Henrik, and others shoud have a *top-list* of packages that are in
2009.2 but not in 2011. The list should be created with the community and a
list should be created (may be going trough Bugzilla and find all package
request for 2009.2 packages). And everyday we should review and go trough this
list. They should me ping, mail, vs.. that I should not forget it Smiley.

I think we could use a new repo for this. A communtiy based repo (not
official). This communtiy based repo could solve all our problems in the first
step. These packages could reside there until a maintainer(Developer) decide to
move these to 2011. (I'll think to take over some of these, but currently I'm
really overload with packages). Anyone who want use a package (like Licq),
could easily download from these community repo.

What do you think ?


So we should create a sort of "top list" of the programs that we want in Pardus 2011.
Or write here what we miss from Pardus 2009.2
I personally would like to have this programs included:

1.Licq (was in Pardus 2009.2)
2.Gyance Improved (new package request)

I included this link in the bug report so they can look when more comments and request for applications will be filled up.
« Last Edit: April 10, 2011, 17:54:59 PM by John A » Logged
John A
Guest
« Reply #1 on: April 11, 2011, 13:56:49 PM »


If look in the report Licq seems to be ready now:


"Licq is now prepared and ready to be used. You can find it under:

http://svn.pardus.org.tr/pardus/playground/fatih.arslan/licq/

Just check it out, and build it with pisi.

I tought it's better to move these packages in our offical repo with review
process. That gives us a better quality and assures that other users can get it
too. Too make this process much more faster i Tought that the Package requested
should be linked to this Bugzilla entry."
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #2 on: April 11, 2011, 15:26:56 PM »

Just check it out, and build it with pisi.
Result:
Quote
sudo pisi bi http://svn.pardus.org.tr/pardus/playground/fatih.arslan/licq/pspec.xml -y
Password:
Outputting packages in the working directory.
pspec.xml                      (13.0 KB)100%     22.85 MB/s [00:00:00] [complete]
actions.py                     (1.0 KB)100%     23.22 MB/s [00:00:00] [complete]
DEBUG: ComponentDB initialized in 0.0245671272278.
DEBUG: RepoDB initialized in 0.0106770992279.
.
.
CMake Warning: The variable, 'CMAKE_LD_FLAGS', specified manually, was not used during the generation.
-- Build files have been written to: /var/pisi/licq-1.5.0-9/work/licq-1.5.0/plugins/rms
DEBUG: return value for "cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_C_FLAGS="-mtune=atom -march=i686 -O2 -pipe -fomit-frame-pointer -fstack-protector -D_FORTIFY_SOURCE=2 -ggdb3 -funwind-tables -fasynchronous-unwind-tables" -DCMAKE_CXX_FLAGS="-mtune=atom -march=i686 -O2 -pipe -fomit-frame-pointer -fstack-protector -D_FORTIFY_SOURCE=2 -ggdb3 -funwind-tables -fasynchronous-unwind-tables" -DCMAKE_LD_FLAGS="" -DCMAKE_BUILD_TYPE=RelWithDebInfo -DCMAKE_MODULE_PATH=/var/pisi/licq-1.5.0-9/work/licq-1.5.0/cmake -DLicq_INCLUDE_DIR=/var/pisi/licq-1.5.0-9/work/licq-1.5.0/include ." is 0
Sandbox violation result:
* mkdir (/root/.subversion -> /root/.subversion)
<< 18x
*** 37 error(s), 2 warning(s)     
Program terminated.                 
Sandbox violations!     
           
Please use 'pisi help' for general help.
Logged
John A
Guest
« Reply #3 on: April 11, 2011, 15:43:00 PM »

Fatih Arslan 2011-04-11 16:39:14 EEST
I think it's fixed with the latest commit. Can you try it again ?
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #4 on: April 11, 2011, 15:51:53 PM »

And after some  
Quote
sudo pisi bi http://svn.pardus.org.tr/pardus/playground/fatih.arslan/licq/pspec.xml -y
Password:
Outputting packages in the working directory.
pspec.xml                      (13.0 KB)100%     22.74 MB/s [00:00:00] [complete]
actions.py                     (1.0 KB)100%     22.74 MB/s [00:00:00] [complete]
DEBUG: ComponentDB initialized in 0.0316410064697.
.
.
[ 15%] Building CXX object src/CMakeFiles/licq.dir/gpghelper.cpp.o
In file included from /var/pisi/licq-1.5.0-9/work/licq-1.5.0/src/gpghelper.h:28:0,  
                       from /var/pisi/licq-1.5.0-9/work/licq-1.5.0/src/gpghelper.cpp:20:
/usr/include/gpgme/gpgme.h:44:23: fatal error: gpg-error.h: No such file or directory
compilation terminated.
make[2]: *** [src/CMakeFiles/licq.dir/gpghelper.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
In file included from /var/pisi/licq-1.5.0-9/work/licq-1.5.0/src/gpghelper.h:28:0,
                        from /var/pisi/licq-1.5.0-9/work/licq-1.5.0/src/daemon.cpp:49:
/usr/include/gpgme/gpgme.h:44:23: fatal error: gpg-error.h: No such file or directory
compilation terminated.
make[2]: *** [src/CMakeFiles/licq.dir/daemon.cpp.o] Error 1
make[1]: *** [src/CMakeFiles/licq.dir/all] Error 2
make: *** [all] Error 2
DEBUG: return value for "make -j5" is 2
Traceback (most recent call last):
  File "/var/pisi/licq/actions.py", line 34, in build
    cmaketools.make()
  File "/usr/lib/pardus/pisi/actionsapi/cmaketools.py", line 77, in make
    if system(command):
  File "/usr/lib/pardus/pisi/actionsapi/shelltools.py", line 255, in system
    error(_("Command \"%s\" failed, return value was %d.") % (command, retValue))
  File "/usr/lib/pardus/pisi/actionsapi/__init__.py", line 27, in error
    raise Error(msg)
pisi.actionsapi.Error: Command "make -j5" failed, return value was 2.
Action script error caught.
*** 1 error(s), 1 warning(s)        
Program terminated.
Result from less than 1 minute ago. monday 11-04-2011 15:49 Dutch time.
« Last Edit: April 11, 2011, 15:53:39 PM by atolboo » Logged
a.palius
Pardus fellow craft
**
Posts: 132


View Profile
« Reply #5 on: April 11, 2011, 16:32:44 PM »

try
Code:
pisi bi http://pakete.pardususer.de/?file=/playground/LinuxFanatic/_from_marchin/licq/pspec.xml -y
« Last Edit: April 11, 2011, 16:35:04 PM by a.palius » Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #6 on: April 11, 2011, 17:52:34 PM »

Result of:
Code:
sudo pisi bi http://pakete.pardususer.de/playground/LinuxFanatic/_from_marchin/licq/pspec.xml -y
after a looooooooong build
Quote
.
.
DEBUG: /usr/lib/licq/licq_rms.so [stripped]
DEBUG: /usr/lib/licq/protocol_msn.so [stripped]
Building package: licq
Creating licq-1.5.0-1-p11-i686.pisi...
Building package: licq-devel
Creating licq-devel-1.5.0-1-p11-i686.pisi...
Building package: licq-qt-data
Creating licq-qt-data-1.5.0-1-p11-i686.pisi...
Building package: licq-qt
Creating licq-qt-1.5.0-1-p11-i686.pisi...  
Building package: licq-kde
Creating licq-kde-1.5.0-1-p11-i686.pisi...
Building package: licq-jabber
Creating licq-jabber-1.5.0-1-p11-i686.pisi...  
Keeping build directory
*** 0 error(s), 1 warning(s)
and
Quote
.
.
DEBUG: /usr/lib/licq/licq_console.so [stripped]
DEBUG: /usr/lib/licq/licq_rms.so [stripped]
Building package: licq
Creating licq-1.5.0-1-p11-x86_64.pisi...
Building package: licq-devel
Creating licq-devel-1.5.0-1-p11-x86_64.pisi...
Building package: licq-qt-data
Creating licq-qt-data-1.5.0-1-p11-x86_64.pisi...
Building package: licq-qt
Creating licq-qt-1.5.0-1-p11-x86_64.pisi...
Building package: licq-kde
Creating licq-kde-1.5.0-1-p11-x86_64.pisi...
Building package: licq-jabber
Creating licq-jabber-1.5.0-1-p11-x86_64.pisi...
Keeping build directory
*** 0 error(s), 1 warning(s)
Logged
a.palius
Pardus fellow craft
**
Posts: 132


View Profile
« Reply #7 on: April 11, 2011, 18:01:16 PM »

I know actions.py is too bloated, but it is possible to compile.
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #8 on: April 12, 2011, 10:43:46 AM »

New result is in >Bug 17706 Comment #13< - Priority and quality order with the package repository.  Grin
Logged
John A
Guest
« Reply #9 on: April 26, 2011, 06:19:36 AM »

I have add Wine and PlayOnLinux to this list and write that in the bug report to. Its often a subject that coming here for the 2011 version.
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!