Welcome, Guest. Please login or register.
April 20, 2014, 00:21:51 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  Japanese language support
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] 2 3 Go Down Print
Author Topic: Japanese language support  (Read 4713 times)
Cnaeus
Pardus fellow craft
**
Posts: 54


View Profile
« on: May 23, 2011, 14:40:15 PM »

Could someone tell me how can I setup some writing support for Japanese language, so that I would be able to write special characters like Kanji and Kana. Usually there is some input method like Microsoft IME in Windows, or IBus in Ubuntu, but I cannot find any in Pardus 2011...
thanks
Logged
gyan000
Pardus fellow craft
**
Posts: 46



View Profile WWW
« Reply #1 on: May 25, 2011, 00:17:21 AM »

Hi,

Same problem for me.
So I usually compile myself ibus.

Create a directory, and download from here all these archives:

ibus-1.3.99.20110228.tar.gz
ibus-anthy-1.2.5.tar.gz
ibus-qt-1.3.1-Source.tar.gz
(versions available can be newer now)

and from here
anthy-9100h.tar.gz

Extract all archives, copy the bash script compil_ibus.sh in this directory and execute it.
You can use the second script to run an application with ibus and test if all is ok

* ibusapp.sh (0.13 KB - downloaded 77 times.)
* compil_ibus.sh (0.79 KB - downloaded 74 times.)
« Last Edit: May 25, 2011, 00:23:04 AM by gyan000 » Logged

---
gyan000 - plus-qu'en-retard
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #2 on: May 25, 2011, 13:31:32 PM »

I wiil try to build a PiSi-package for this Grin
Logged
Cnaeus
Pardus fellow craft
**
Posts: 54


View Profile
« Reply #3 on: May 25, 2011, 14:56:36 PM »

Wow, a PiSi Package would be great...
Even though, gyan's method installed IBus fine for me - thanks gyan -, but after that IBus fails to start Sad
It looks like a bug in kde: the ibus icon appears on taskbar, but after a little while it just disappears and the window never pops up...
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #4 on: May 28, 2011, 15:56:03 PM »

A big for a.palius, who made the build files

The first version of
anthy-9100h-1-p11-nn.pisi
ibus-1.3.9-1-p11-nn.pisi
ibus-anthy-1.2.6-1-p11-nn.pisi
ibus-qt-1.3.1-1-p11-nn.pisi
is now available from  >2. Additional (non-official) package source: pardususer.de<.

I don't know (in fine detail) how to test these packages and what the individual packages (should) do.

I only know that ibus results in two menu entries
1. Utility > IBus (Input Method Framework)
2. Settings > IBus Preferences

And in konsole I get:
Quote
atolboo@pardus2011 ~ $ ibus-daemon --xim
Can not execute default config program
atolboo@pardus2011 ~ $ ibus-setup
Traceback (most recent call last):
  File "/usr/share/ibus/setup/main.py", line 31, in <module>
    import ibus
  File "/usr/lib/python2.7/site-packages/ibus/__init__.py", line 26, in <module>
    from common import *
  File "/usr/lib/python2.7/site-packages/ibus/common.py", line 54, in <module>
    from xdg import BaseDirectory
ImportError: No module named xdg

Suggestions how to improve and what the end result should be are welcome Grin
« Last Edit: May 29, 2011, 13:16:02 PM by atolboo » Logged
gyan000
Pardus fellow craft
**
Posts: 46



View Profile WWW
« Reply #5 on: May 28, 2011, 16:56:27 PM »

Ah, great !
The PiSi packages are fine, I installed them and it  seems to work fine.
Many thanks to a.palius.  Smiley

You miss python-pyxdg package.
When ibus is working correctly, you simply just have to press CTRL+SPACE (by default) to start writing using kana.
I've joined a screenshot.


* ibus_example.png (88.88 KB, 983x529 - viewed 139 times.)
« Last Edit: May 28, 2011, 18:54:52 PM by gyan000 » Logged

---
gyan000 - plus-qu'en-retard
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #6 on: May 28, 2011, 17:23:43 PM »

Thanks for the feedback
And this
You miss python-pyxdg package.
means that there will definitely come an update. Wink
Logged
a.palius
Pardus fellow craft
**
Posts: 132


View Profile
« Reply #7 on: May 29, 2011, 08:22:20 AM »

I've corrected build files.
Updated binary package should be available in pardususer.de repo soon.
Code:
export GTK_IM_MODULE=ibus
export QT_IM_MODULE=ibus
export XMODIFIERS="@im=ibus"
These lines have been added to /etc/profile.d/ibus.sh file, so the next time you log in each of these variables will be set up.
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #8 on: May 29, 2011, 13:15:16 PM »

I've corrected build files.

Updated binary package should be available in pardususer.de repo soon.
ibus-1.3.9-2-p11-nn.pisi is now available as update

I now get ibus-preferences.png
But it's still not clear to me what menu entry 1. Utility > IBus (Input Method Framework)
with
Quote
atolboo@pardus2011 ~ $ ibus-daemon --xim
current session already has an ibus-deamon
is supposed to do


* ibus-preferences.png (102.47 KB, 1366x523 - viewed 122 times.)
Logged
gyan000
Pardus fellow craft
**
Posts: 46



View Profile WWW
« Reply #9 on: May 30, 2011, 00:27:57 AM »

Ok, now, I have the ibus systray icon that work fine and the toolbar is displayed correctly.
(since I use only one method to write japanese it was not useful for me, but it show that the package is well done.)

Now, I can write japanese directly in GTK apps whereas before I couldn't.  Cool
But, even if the variables for the default input method are set :
Code:
gyan011@gyanopolis ~ $ env | grep ibus
QT_IM_MODULE=ibus
XMODIFIERS=@im=ibus
GTK_IM_MODULE=ibus

I can use ibus only when I launch application from a konsole.
The only workaround I found is add the
Code:
export GTK_IM_MODULE=ibus
export QT_IM_MODULE=ibus
export XMODIFIERS="@im=ibus"

in /usr/bin/startkde but that's a dirty solution and I don't know where to set these variables. It's the last problem I see with this very useful new package.

@atolboo.
Since the variables are automatically set when ibus is started, it's useless to write ibus-daemon --xim to use ibus in a konsole.
Logged

---
gyan000 - plus-qu'en-retard
Cnaeus
Pardus fellow craft
**
Posts: 54


View Profile
« Reply #10 on: June 07, 2011, 13:24:27 PM »

Um, the ibus icon now appears, only that I can't add any input method... I'm sure I installed the ibus-anthy package, but still cannot add it to input method list!  Huh?


* Error 3.jpg (29.25 KB, 470x528 - viewed 109 times.)
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #11 on: June 07, 2011, 14:02:09 PM »

I'm sure I installed the ibus-anthy package, .......
To be 100% sure, test this with the following command in console:
Code:
pisi info ibus-anthy
Logged
a.palius
Pardus fellow craft
**
Posts: 132


View Profile
« Reply #12 on: June 07, 2011, 17:31:45 PM »

... but still cannot add it to input method list!  Huh?

Updated anthy, ibus and ibus-anthy packages should appear soon in pardususer.de repo and you will see something like this (2nd from the left).


* jp.png (6.35 KB, 267x30 - viewed 106 times.)
« Last Edit: June 07, 2011, 17:33:39 PM by a.palius » Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #13 on: June 07, 2011, 22:16:23 PM »

  updated packages are now available
Logged
Cnaeus
Pardus fellow craft
**
Posts: 54


View Profile
« Reply #14 on: June 09, 2011, 16:06:33 PM »

I can now add japanese language, but still, when I try to switch usig ctrl+space, nothing happens. When I click on Ibus icon at taskbar, it says "no input window" ... Huh?
Logged
Pages: [1] 2 3 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!