Welcome, Guest. Please login or register.
April 23, 2014, 09:10:44 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  Japanese language support
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: 1 2 [3] Go Down Print
Author Topic: Japanese language support  (Read 4758 times)
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #30 on: June 20, 2011, 11:28:56 AM »

Will be tested and .......
I think I found the problem
When I installed the package on 19-06-2011 with "sudo pisi it ibus-anthy -y", I got
Quote
Downloading 3 / 5
Package ibus found in repository pardususer.de
ibus-1.3.9-3-p11-i686.pisi     (694.0 KB)100%    899.24 KB/s [00:00:00] [complete]
And the latest version is ibus-1.3.9-4-p11-i686.pisi Grin
Investigation continues
« Last Edit: June 20, 2011, 11:39:05 AM by atolboo » Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #31 on: June 20, 2011, 12:35:43 PM »

Investigation continues
The problem is caused by my fault(s) and can't happen again as I have removed ibus-1.3.9-3 from the pardususer.de repo.
Sorry for the inconvenience Embarrassed

Here are my new results.
(I will also modify my previous results)

1. Install "ibus-anthy' in Package Manager or in konsole
Code:
sudo pisi it ibus-anthy -y
As a result (dependencies) also python-pyxdg, notify-python, ibus and anthy are installed.

2. Start Settings > IBus Preferences and add Anthy to Input Method (as can be seen in the middle of this ibus-preferences.png)
Anthy-disabled.png is now visible in Systray.

3. Logout > Login or restart the computer to activate Anthy.

4. Now I can toggle Anthy support (see anthy-enabled.png <> anthy-disabled.png below) with CTRL+Spacebar.

  in kwrite-ibus-anthy.png and konsole-ibus-anthy1.png
Here you can see the relation of some Latin <> Japanese characters.
And maybe there is a list somewhere of all Latin <> Japanese characters Huh?

5. Result in Firefox is shown in this ff-anthy.png.


* anthy-enabled.png (3.71 KB, 84x28 - viewed 209 times.)

* anthy-disabled.png (3.34 KB, 83x28 - viewed 203 times.)

* kwrite-ibus-anthy.png (24.51 KB, 326x168 - viewed 102 times.)

* konsole-ibus-anthy1.png (21.36 KB, 328x161 - viewed 117 times.)
« Last Edit: July 16, 2011, 10:47:32 AM by atolboo » Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #32 on: June 20, 2011, 13:37:59 PM »

Still not working. I
Try
Code:
sudo pisi up -y
followed by
Code:
sudo pisi it python-pyxdg notify-python ibus anthy ibus-anthy --reinstall -y
Logged
Cnaeus
Pardus fellow craft
**
Posts: 54


View Profile
« Reply #33 on: June 21, 2011, 22:00:09 PM »

WOW, sounds like a solution, but I cannot try it now, as I do not have direct internet acces for my pardus machine, but hopefully I will have it in 3-4 days... thank you for your investigation, you're a genius, lol!
Logged
Cnaeus
Pardus fellow craft
**
Posts: 54


View Profile
« Reply #34 on: June 25, 2011, 12:02:12 PM »

Heartbreaking, but still don't work...

pisi info ibus says:
Quote
Name                 : ibus, version: 1.3.9, release: 4
is this the right one?
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #35 on: June 25, 2011, 22:03:37 PM »

Heartbreaking, but still don't work...
I can only report that after installing ibus-anthy I have:
Quote
Installed package:
python-pyxdg, version: 0.19,     release: 3
notify-python,  version: 0.1.1,    release: 7
ibus,                 version: 1.3.9,    release: 4
anthy,               version: 9100h, release: 2
ibus-anthy,      version: 1.2.6,    release: 2

After making the required IBus Preferences and as the lines
export GTK_IM_MODULE=ibus
export QT_IM_MODULE=ibus
export XMODIFIERS="@im=ibus"
are now in
...... added to /etc/X11/Xsession.d/ibus.sh script in latest release (4)
it's now necessary  to Leave... > Logout > Login (X-system needs a restart) and anthy is now doing on my computer.
Logged
Cnaeus
Pardus fellow craft
**
Posts: 54


View Profile
« Reply #36 on: July 13, 2011, 13:05:33 PM »

Oh, I forgot to mention that I was given a temporary solution by a.palius:
Code:
sudo ln -s /etc/X11/Xsession.d/51-ibus.sh /etc/profile.d/ibus.sh

this code lets you use ibus, its only that it works for apps opened from console alone. Just in case if somebody else has the same problem as me...
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #37 on: July 16, 2011, 10:45:15 AM »

Result in Firefox 5.0 of P2011.1 Wink


* ff-anthy.png (3.51 KB, 142x75 - viewed 172 times.)
Logged
Cnaeus
Pardus fellow craft
**
Posts: 54


View Profile
« Reply #38 on: July 28, 2011, 00:18:41 AM »

Ok, when I saw that pardus 2011.1 came out, I decided to do a full reinstall, and, I'm happy to report that ibus works fine for me now Cheesy With japanese writing support enabled, I thing I will stick with Pardus for a long time, cuz this really is a great OS...

皆さん、ありがとうございます! v(^_^)v

SOLUTION SUMMARY:
1) Add the following address to your PiSi repository (32bit):
Quote
or for 64bit OS add:
Quote
(I dont know if ibus currently works for 64bit though)

2) Install "ibus"&"ibus anthy"&"ibus qt" packages with PiSi
3) Install the "aquafont" package for additional japanese fonts (note that you will have to use japanese fonts in applications like libreoffice, or you will get squares instead of kanji)
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #39 on: July 28, 2011, 12:26:35 PM »

Ok, when I saw that pardus 2011.1 came out, I decided to do a full reinstall....
This ^^^ isn't really necessary as a full-update of (an already installed) P2011 will result in P2011.1 Grin
Logged
Cnaeus
Pardus fellow craft
**
Posts: 54


View Profile
« Reply #40 on: July 31, 2011, 12:46:57 PM »

Yeah, I did that first! But when the problem persisted, I decided to go the hard way Wink So I don't think my problem was about versions, it's rather that I messed something up with the pre-release ibus versions... Tongue
Logged
Pages: 1 2 [3] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!