Welcome, Guest. Please login or register.
April 18, 2014, 07:49:48 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Pardus for beginners
| | |-+  [Solved]Poedit problem
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: [Solved]Poedit problem  (Read 1509 times)
zvacet
Pardus fellow craft
**
Posts: 97



View Profile
« on: June 09, 2011, 19:07:29 PM »

I installed Poedit,but I can not use it.I tried to start it from menu and for some time it look like it will start but nothing.I also tried  to run it with "run command"with no luck.So I remove it and try to install from cli.Same result.Installing and starting software is so easy and that is why I don´t understand what is going on.
« Last Edit: June 10, 2011, 18:08:19 PM by zvacet » Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #1 on: June 09, 2011, 19:53:41 PM »

To get more info about your problem, start the program in konsole with
Code:
poedit
I always use Lokalize (part of kdesdk) for my EN-NL translation jobs with .po files.
And after installing I can start Poedit without any problems.
Logged
zvacet
Pardus fellow craft
**
Posts: 97



View Profile
« Reply #2 on: June 09, 2011, 21:59:52 PM »

Code:
bash: /usr/bin/poedit: cannot execute binary file
Logged
SW
Guest
« Reply #3 on: June 09, 2011, 22:17:47 PM »

I have P2011 i686  (32Bit) and my poedit is starting without any problem   Undecided

BTW, You can translate via transifex 'on the fly' without using poedit.
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #4 on: June 09, 2011, 22:38:15 PM »

I couldn't find it in P2011 Huh?
My result (on 2 computers in P2009) is in the image.
And to re-install the package:
Code:
sudo pisi it poedit --reinstall


* poedit.png (103.44 KB, 807x823 - viewed 118 times.)
Logged
SW
Guest
« Reply #5 on: June 09, 2011, 23:08:05 PM »

It is still in testing!  Roll Eyes
http://packages.pardus.org.tr/pardus/2011/testing/i686/poedit-1.4.6.1-5-p11-i686.pisi
Logged
zvacet
Pardus fellow craft
**
Posts: 97



View Profile
« Reply #6 on: June 09, 2011, 23:52:22 PM »

@SW

I´m glad that works for you ,but that doesn´t solve my problem ( I have one more,because it means package works).Well,I´m using Pardus just for few days but I don´t think package is in testing repo,because I don´t have it ( at least I think that).Here is my repo list

Code:
pisi list-repo
pardus [active]
   http://packages.pardus.org.tr/pardus/2011/stable/i686/pisi-index.xml.xz
P2011 [active]
   http://paketler.pardus-linux.org/P2011/i686/pisi-index.xml.xz
PardusUser.de [active]
   http://pakete.pardususer.de/pardus-2011/i686/pisi-index.xml.xz
comak [active]
   http://comak64.comu.edu.tr/comak/pisi-index.xml.xz

Code:
pisi info poedit

give me this

Code:
Installed package:
Name                : poedit, version: 1.4.6.1, release: 5
Summary             : A cross-platform Gettext catalogs (.po files) editor
Description         : This program is GUI frontend to GNU Gettext utilities and
                      catalogs editor/source code parser. It helps with
                      translating application into another language. For details
                      on principles of the solution used, see GNU Gettext
                      documentation or wxWidgets' wxLocale class reference.
Component           : desktop.gnome.addon
Provides            :
Dependencies        : gtk2 wxGTK gtkspell
Distribution        : Pardus, Dist. Release: 2011
Architecture        : x86_64, Installed Size: 2.52 MB
Reverse Dependencies:

Package found in comak repository:
Name                : poedit, version: 1.4.6.1, release: 5
Summary             : A cross-platform Gettext catalogs (.po files) editor
Description         : This program is GUI frontend to GNU Gettext utilities and
                      catalogs editor/source code parser. It helps with
                      translating application into another language. For details
                      on principles of the solution used, see GNU Gettext
                      documentation or wxWidgets' wxLocale class reference.
Component           : desktop.gnome.addon
Provides            :
Dependencies        : gtk2 wxGTK gtkspell
Distribution        : Pardus, Dist. Release: 2011
Architecture        : x86_64, Installed Size: 2.52 MB, Package Size: 638.00 KB
Reverse Dependencies:

poedit package is not found in source repositories

EDIT:I tried to reinstall with no joy.  :'(
« Last Edit: June 09, 2011, 23:57:57 PM by zvacet » Logged
SW
Guest
« Reply #7 on: June 10, 2011, 04:40:22 AM »

First thing, You have x86_64 and second thing is You have comak repo added in package-manager. Comak ist not an official repo and maybe it is not tested so good as the offical one.

I suggest You to install podeit from official testing repo, because it worked for me (i686)

Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #8 on: June 10, 2011, 10:48:34 AM »

I suggest You to install podeit from official testing repo, because it worked for me (i686)
This can be done with the following command (for P2011_i686 and to fulfill all dependencies)
Code:
sudo pisi it http://packages.pardus.org.tr/pardus/2011/testing/i686/wxGTK-2.8.12-17-p11-i686.pisi http://packages.pardus.org.tr/pardus/2011/testing/i686/wxBase-2.8.12-17-p11-i686.pisi http://packages.pardus.org.tr/pardus/2011/testing/i686/poedit-1.4.6.1-5-p11-i686.pisi -y --reinstall
It's a long one Grin
Logged
zvacet
Pardus fellow craft
**
Posts: 97



View Profile
« Reply #9 on: June 10, 2011, 18:06:25 PM »

@ SW

You are right.I replace 64 bit comak with 32 bit one.After that I was able to install Poedit.Tnx!
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!