Welcome, Guest. Please login or register.
April 23, 2014, 09:15:10 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Laptop
| | |-+  and then it all went down...
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: 1 2 [3] 4 5 ... 8 Go Down Print
Author Topic: and then it all went down...  (Read 13638 times)
owiknowi
Guest
« Reply #30 on: June 29, 2011, 12:15:38 PM »

created the file named autostart in (pardus kurumsal 2): /home/username/.kde3.5/autostart/ and made it executable.
rebooted and as usual the network manager wanted its password. gave it, and network said i was connected.
when trying to update the comment was: network error (please check your network connections and try again.)

question: the second command line is: iwconfig wlan0 essid ..... key s:.....
behind key s: there's a : (and no space before password), behind essid tere's not (just one empty space before essid name)?
« Last Edit: June 29, 2011, 12:41:23 PM by owiknowi » Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #31 on: June 29, 2011, 20:52:00 PM »

Hi owiknowi,
Since it looks like DavidD is having problems with Pardus 2011, then it probably wouldn't make a difference.

And, another shot in the dark: I've been reading up on avahi-daemon, as there is one config file that is different in Pardus (2011 or Corporate2) and Debian and Ubuntu and that is the file /etc/avahi/avahi-daemon.conf in the following section:

browse-domains=0pointer.de, zeroconf.org
use-ipv4=yes
use-ipv6=no

In Debian and Ubuntu, the first line browse-domains is commented out with #, and use-ipv6= says 'yes'.

I'm sure there are lots of other files that are different in Pardus that shouldn't matter, but I just thought this should be mentioned, in case zeroconf doesn't like hidden wireless? 

Code:
sudo netstat -ulnp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
udp        0      0 0.0.0.0:631             0.0.0.0:*                           814/cupsd
udp        0      0 0.0.0.0:50028           0.0.0.0:*                           798/avahi-daemon: r
udp        0      0 0.0.0.0:5353            0.0.0.0:*                           798/avahi-daemon: r
udp        0      0 192.168.122.1:53        0.0.0.0:*                           959/dnsmasq
udp        0      0 0.0.0.0:67              0.0.0.0:*                           959/dnsmasq
udp        0      0 :::5353                 :::*                                798/avahi-daemon: r
udp        0      0 :::44823                :::*
798/avahi-daemon: r

Lisa Marie
P.S.  That would be Sherlock Holmes.  I'm sure atolboo has en emoticon for Sherlock Holmes.  Cheesy
Logged
owiknowi
Guest
« Reply #32 on: June 30, 2011, 09:06:00 AM »

hi lisa marie,

thanks again for your reply.
looked into avahi-daemon.conf in mint 11 whilst it is connected to the hidden wireless:
#browse-domains=0pointer.de, zeroconf.org
use-ipv4=yes
use-ipv6=yes

in pardus avahi-daemon.conf looks different (not connected to the hidden wireless, obvious):
browse-domains=0pointer.de, zeroconf.org
use-ipv4=yes
use-ipv6=no

exactly as you already mentioned.

attached you'll find two files -from mint 11 and pardus- with the output of sudo netstat -ulnp.

i'll take a closer look at the daemon files and its settings with 'unix and linux system administration handbook' at hand.
must say that g.i.s., my profession, is rather simple compared to system administration and such...

* pardus_netstat-ulnp.txt (0.62 KB - downloaded 76 times.)
* min11_netstat-ulnp.txt (1.21 KB - downloaded 96 times.)
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #33 on: June 30, 2011, 21:39:00 PM »

Since I had problems with dial up in Corporate2, I initially looked into avahi and as root, manually edited the avahi-daemon.conf file to mimic the Debian-based one.  It didn't make a difference for me for what I now believe is another problem.  But, I believe for that particular file to be changed you have to stop, and then start avahi-daemon service, otherwise it will re-write a new file, avahi-daemon.conf.newconfig, which is just like the original.  You might try changing it to see if it makes a difference.  
I don't know how to stop and then start avahi-daemon by command line.  I looked in man pages and only found --kill and --reload.
Oops, here it is:

sudo service ahavi start 
and
sudo service ahavi stop


I like to waste your time.... Grin but you can also compare what programs start at log in, or maybe these start prior to login, for Pardus:
/etc/conf.d/
Debian-based has them in /etc/init.d.

Hopefully DavidD will get a suggestion or answer for his bug report and will resolve this for you, too.
« Last Edit: June 30, 2011, 21:47:11 PM by Lisa » Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #34 on: June 30, 2011, 22:36:41 PM »

Also have a look in my momentary result.
Maybe it also is valid for Kurumsal 2 Huh?
Logged
DavidD
Pardus fellow craft
**
Gender: Male
Posts: 73



View Profile
« Reply #35 on: July 01, 2011, 00:03:11 AM »

Hope you two don't mind my joining this discussion, since it is on a topic near and dear to me  Wink

... I believe for that particular file to be changed you have to stop, and then start avahi-daemon service, otherwise it will re-write a new file, avahi-daemon.conf.newconfig, which is just like the original.  You might try changing it to see if it makes a difference.

I made changes to avahi-daemon.conf and they stayed put through a shutdown/reboot. I commented out the line under [services] that is also commented out in Ubuntu, etc., according to the info I've seen here. Ultimately, it made no difference. But somehow I'm now getting a connection to my hidden wireless network without changes to that daemon and even without the bash scripts Atolboo suggested. Go figure. That's on the Compaq V2000 laptop.

Quote
Hopefully DavidD will get a suggestion or answer for his bug report and will resolve this for you, too.

I'm not holding out hope for that. I think the problem is with Network Manager. It apparently has no means to initiate the connection but only to configure it. In my other thread I've suggested that in other distros I've seen Network Manager with the option to "Connect to Hidden Wireless Network" (configuration) and "connect." I can configure 'til I'm blue in the face but without some "switch" to turn it on, nothing happens.

OK, back to your regularly scheduled program....  Smiley

David
Logged

"The most tragic pathologies we've experienced in human history result from the catastrophic way we deal with otherness." - D. Gordis
owiknowi
Guest
« Reply #36 on: July 01, 2011, 10:13:54 AM »

thanks for the replies and options _O_

since it is painfully clear that murphy's law is pulling its weight on several notebooks c.q. chipsets, a preliminary conclusion:
the newer hardware is just not (yet) fully supported in linux (ouch...). parts will work with some distro's and other parts won't.
this is, imho, due to the pretty nasty policie$ that come with closed source drivers.

like mint 11: it connects just fine to the hidden network but is unable to halt/reboot, the latter not occurring in pardus.
in (k)ubuntu 10.04, 10.10 and 11.04 nor the wireless comes up, nor does bluetooth and they're neither able to halt/reboot.
the system freezes completely, also when logged in as root, and one has to press the power button till the computer shuts down.

red hat based distro's -scientific and centos- also have similar problems.

searching for most of the day on several penguin forums, i found these troubles are pretty common with newer computers, and there doesn't seem to be a solution just yet.

so it's not a problem with open source software as such, but one for open source software, caused by (see above).
with newer distro's this, and many other problems, will probably be solved.

for now i'll just keep tinkering, even when blue in the face Wink , that's for sure!
should i post any results still here or open a new topic? don't know what's best since this is has become a rather long topic.

p.s. lisa marie: a huge benefit that comes along with computer troubles, is that one has to wait a lot and thus can listen to music, like joseph haydn's 114 symphonies (no waste of my time...) Smiley
« Last Edit: July 01, 2011, 10:15:36 AM by owiknowi » Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #37 on: July 01, 2011, 17:27:17 PM »

I'm only here to create a diversion, as I don't know what I'm talking about.  Grin  I have a strong weakness for perplexing problems.  This one definitely caught my interest, and I appreciate you putting up with my suggestions and trying them or giving outputs of errors, etc.

Final suggestion would be to try WICD instead of NetworkManager.
Lisa Marie
Logged
owiknowi
Guest
« Reply #38 on: July 01, 2011, 20:03:45 PM »

@ lisa marie
well in that case maybe you've found your match Wink
i like to keep mucking about with computers till they finally become desperate and shut them selfs down, for good...

but what's more: i enjoy pardus in general and this forum especially.

so next thing to do is tinker a bit more and install wicd, as you've so suggested, and report back here.

meanwhile, thanks to a link from atolboo, i found another very good pardus forum in germany:
http://www.pardususer.de/
a lot is in german but also some in english.
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #39 on: July 01, 2011, 20:40:12 PM »

owiknowi, Thanks for the link!  Google language tools will be put to use.

I'm not sure if you need to install build-essentials first to install WICD?  I wish I could remember if I did or not on my first install of Pardus 2011.  But, if you do:
sudo pisi install -c system.devel
about 63 packages for Corporate2.

And now, for my wee problem, I'm going to install 'compat32-dbus' to see if that does anything for my hal/dbus dial up problem.
Lisa Marie

Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #40 on: July 01, 2011, 20:47:03 PM »

a lot is in german but also some in english.
And fortunately I learned some German at school some 45 years ago (and some practice in the years after that).
I did already ask for suggestions here Grin

I'm not sure if you need to install build-essentials first to install WICD?
If WICD is in the repo, the answer is: NO Wink
Logged
owiknowi
Guest
« Reply #41 on: July 01, 2011, 20:57:54 PM »

danke sehr, atolboo.

ich werde mich das morgenfrüh mahl ganz genau anschauen.

wie immer mit grüß,
owiknowi (nein, nicht der auf youtube, der hat nur meinen namen geklaut)

well, that's a while back i had to deal with german, fortunately i only use upper case characters in my posts Wink
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #42 on: July 01, 2011, 21:09:22 PM »

ich werde mich das morgenfrüh mahl ganz genau anschauen.

wie immer mit grüß,
Ist sehr Deutsch Grin (<< ist nicht meine Muttersprache)
« Last Edit: July 01, 2011, 21:11:01 PM by atolboo » Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #43 on: July 02, 2011, 00:14:38 AM »

Moin moin,  Grin

I installed wicd from this Fedora 9 how to.  Whether it worked or not is another matter, as again, I don't have wireless.   Roll Eyes
Lisa Marie
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #44 on: July 02, 2011, 15:12:15 PM »

question: the second command line is: iwconfig wlan0 essid ..... key s:.....
behind key s: there's a : (and no space before password), behind essid tere's not (just one empty space before essid name)?
Have a in:
http://wirelessdefence.org/Contents/LinuxWirelessCommands.htm
and also in there "Useful Linux Wireless Commands"
Logged
Pages: 1 2 [3] 4 5 ... 8 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!