Welcome, Guest. Please login or register.
April 17, 2014, 18:34:46 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  General
| |-+  As seen on the internet
| | |-+  helpful wireless how-to for Broadcom chipsets
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] 2 Go Down Print
Author Topic: helpful wireless how-to for Broadcom chipsets  (Read 4120 times)
Lisa
Pardus Guru
****
Posts: 841



View Profile
« on: July 18, 2011, 20:06:40 PM »

Hi,
I'm still reading about this topic as I see it is often a problem of late getting wireless to work.

Here is a helpful how-to.

Always first check which wireless you are using with command:
Code:
lspci
it is usually the last entry. 

In Pardus, one way to get it to work is add an entry to the file:
/etc/modules.autoload.d/kernel-2.6
as explained  here.  If "wl" doesn't work, then try "b43" instead.  Reboot.  I've been looking over both Pardus Turkish forums and thanks to their suggestions on this topic, they've gotten many folks' wireless to work.

Another thing to check is if you have Windows installed, boot into it and make sure the wireless switch is on, then reboot into Linux.  Some people have it turned off in Windows which effects Linux not being able to see connection.

 Cheesy I need to try this out on the iMac as it has an airport extreme card with wireless firmware version:   Broadcom BCM43xx 1.0 (4.170.46.9), the infamous b43. 
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #1 on: July 19, 2011, 17:12:16 PM »

Cheesy I need to try this out on the iMac as it has an airport extreme card with wireless firmware version:   Broadcom BCM43xx 1.0 (4.170.46.9), the infamous b43. 

And I also topics that it's working out-of-the-box in Pardus.
Logged
AndrewB
Newbie
*
Posts: 4


View Profile
« Reply #2 on: July 22, 2011, 02:20:32 AM »

Hi,
I'm still reading about this topic as I see it is often a problem of late getting wireless to work.

Here is a helpful how-to.

Always first check which wireless you are using with command:
Code:
lspci
it is usually the last entry.  

In Pardus, one way to get it to work is add an entry to the file:
/etc/modules.autoload.d/kernel-2.6
as explained  here.  If "wl" doesn't work, then try "b43" instead.  Reboot.  I've been looking over both Pardus Turkish forums and thanks to their suggestions on this topic, they've gotten many folks' wireless to work.

Another thing to check is if you have Windows installed, boot into it and make sure the wireless switch is on, then reboot into Linux.  Some people have it turned off in Windows which effects Linux not being able to see connection.

 Cheesy I need to try this out on the iMac as it has an airport extreme card with wireless firmware version:   Broadcom BCM43xx 1.0 (4.170.46.9), the infamous b43.  

Thanks for posting this!  A week ago I had Pardus installed and tried many things to try to get my Broadcom 43225 to work, but I failed, and I gave up and installed Ubuntu for the time being.  I got accepted into this forum, so I really hope I can get my problems worked out because Pardus seems like an amazing distro.  I tried these steps that you suggested, but they did not fix my problem.  

Any suggestions?

Thank you!
« Last Edit: July 22, 2011, 02:23:31 AM by AndrewB » Logged
AndrewB
Newbie
*
Posts: 4


View Profile
« Reply #3 on: July 22, 2011, 03:24:49 AM »

This link helped a little...
http://www.linuxquestions.org/questions/linux-wireless-networking-41/howto-bcm43xx-broadcom-drivers-462995/
After fooling around, my card seems to be turned on - I can select the wireless tab in the network manager Tongue - however, it does not connect to my router.
Logged
dedebekri
Pardus fellow craft
**
Posts: 72


View Profile
« Reply #4 on: July 23, 2011, 08:10:28 AM »

This link helped a little...
http://www.linuxquestions.org/questions/linux-wireless-networking-41/howto-bcm43xx-broadcom-drivers-462995/
After fooling around, my card seems to be turned on - I can select the wireless tab in the network manager Tongue - however, it does not connect to my router.
Check http://tr.pardus-wiki.org/Donan%C4%B1m:Lenovo_B560#Kablosuz_a.C4.9F , maybe it can be helpful.

I also have a Lenovo B560 which has a Broadcom4313 chipset, not only it solved my problem, but also let me understood the logic.
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #5 on: July 23, 2011, 15:06:36 PM »

And >this translation< of the above Wiki page. Grin
Thanks to dedebekri
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #6 on: July 23, 2011, 18:53:48 PM »

Sorry I couldn't give further advice, Andrew.  Mainly I have been using google language tools to translate the Özgürlük İçin forum, and then reading the topics under "internet", "network connections" and "netbook".  That's where I've been getting my info.  

Edited to add the whole enchilada, as the saying goes, for Turkish Pardus Wiki for Notebooks

And yet another translated how to here for Acer Aspire 5741G with Broadcom 4357 802.11 b / g / n Wireless WiFi Link wireless network card.

I wish I could find the link, but someone got their wireless working when they removed two of the Broadcom packages, either the b43 or the module wl, as it seemed to be conflicting with their wireless.  Sorry, I can't find the thread at that forum.  
P.S. Fixed the link, I hope.

« Last Edit: July 23, 2011, 19:18:56 PM by Lisa » Logged
AndrewB
Newbie
*
Posts: 4


View Profile
« Reply #7 on: July 23, 2011, 21:11:04 PM »

Thanks for the reply!

Two nights ago I stayed up until 4:30am because I knew I was on to something to fix this problem.  Thanks to one of your links, I was able to connect my BCM43225 to the internet!  It frustrated me, because I had spent hours and hours trying to figure it out, and had failed...In the end, one terminal command under root was needed to fix it (at least for me)...

Quote
# modprobe wl

All was great until a restart, where it wouldn't connect again (until I initiated that command).  So I figured I needed to add a script to be run at startup.  I am brand new at making scripts, but this one seemed very simple.  So I made a .sh, went to System Settings>Startup and Shutdown and tried adding my script there.   That didn't work I think because it needed root access.  I did a search on Pardus' WorldForum and came across some instructions on where to put my script.

I edited /etc/conf.d/local.start and added...

Quote
#!/bin/bash
modprobe wl

Rebooted and it worked!

I hope this helps others.
« Last Edit: July 25, 2011, 02:58:47 AM by AndrewB » Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #8 on: July 23, 2011, 22:09:38 PM »

Rebooted and it worked!


I hope this helps others.
for the feedback.
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #9 on: July 25, 2011, 01:20:29 AM »

That's nice work, AndrewB!  That's the first time I've seen a script used to do the start up probing. 
You're definitely a Pardus Guru!
Lisa Marie
Logged
AndrewB
Newbie
*
Posts: 4


View Profile
« Reply #10 on: July 25, 2011, 03:14:53 AM »

That's nice work, AndrewB!  That's the first time I've seen a script used to do the start up probing. 
You're definitely a Pardus Guru!
Lisa Marie

Haha I wouldn't say that - I just got lucky.  But thanks  Cheesy
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #11 on: July 25, 2011, 16:37:02 PM »

No.  Hard work. If you stayed up until 4:30A.M.!  I couldn't do that. 
I'm about to try this on my setup, though I don't use wireless but a 56K external modem.  Here goes...
Lisa Marie
Logged
Mahmood
Pardus fellow craft
**
Posts: 69


View Profile
« Reply #12 on: December 12, 2011, 12:48:46 PM »

Yesterday, i installed Pardus on a friend's laptop. However, since it had a broadcom wifi chip, it did not work automatically. I tried modprobe wl and it worked.

Now, after reading this thread and searching on the net, i was thinking of making this permanent and also future proof (so that it survives version upgardes of pardus).

Solution 1: (as suggested)

putting modprobe wl in /etc/conf.d/local.start

Solution 2:

putting wl in /etc/modules.autoload.d/kernel-2.6 (this does not seem to be future proof to me as kernels will be upgraded in future)

Solution 3:

In /etc/modprobe.d, modify broadcom-wl.conf file

There is a line which tells to install wl and remove b43 and then ignores install. probably removing the second part should be enough?

Solution 4:

add wl in /etc/rc.conf file in the modules array

Which of the above is more future-proof?

QUESTION 2:

In case more than one drivers support a chipset (e.g., b43 and wl), which one to use.
« Last Edit: December 12, 2011, 12:52:12 PM by Mahmood » Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #13 on: December 12, 2011, 15:51:43 PM »

I would think that altering /etc/conf.d/local.start is the best way to go as this file is made just for personalizing and I would think updates for modprobe rules would not effect it.
One can always change it back to default to check in future if this is resolved, especially after modprobe, udev, module and kernel updates. 

The file. /etc/rc.conf,  is a Debian distro file, which I think I have also seen it in Fedora, but not sure.  I think it's equivelant in Pardus are the files under /etc/conf.d .
Lisa Marie
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #14 on: December 12, 2011, 20:24:06 PM »

Solution 1: (as suggested)
Comes from
Quote
atolboo@wind-pardus ~ $ pisi sf local.start
Zoekt naar local.start
Pakket baselayout bevat bestand /etc/conf.d/local.start

Solution 2:
Quote
atolboo@wind-pardus ~ $ pisi sf kernel-2.6
Zoekt naar kernel-2.6
Pakket baselayout bevat bestand /etc/modules.autoload.d/kernel-2.6
Pakket kernel bevat bestand /boot/kernel-2.6.37.6

Solution 3:
Quote
atolboo@wind-pardus ~ $ pisi sf broadcom-wl.conf
Zoekt naar broadcom-wl.conf
Pakket module-broadcom-wl-userspace bevat bestand /etc/modprobe.d/broadcom-wl.conf

Solution 4:
Quote
atolboo@wind-pardus ~ $ ls -l /etc/rc.conf
ls: kan geen toegang krijgen tot /etc/rc.conf: Bestand of map bestaat niet   <<< does not exist
And thus not from any package.
Logged
Pages: [1] 2 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!