Welcome, Guest. Please login or register.
April 17, 2014, 23:24:16 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  [Solved] Pardus 2011.1 ACPI problem in plasma/kde
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: 1 [2] Go Down Print
Author Topic: [Solved] Pardus 2011.1 ACPI problem in plasma/kde  (Read 4908 times)
Sandro
Pardus fellow craft
**
Posts: 53



View Profile
« Reply #15 on: July 30, 2011, 20:19:42 PM »

To fix this, I have to open terminal and enter:
kded
or
kded --new-startup
Very interesting, an interesting coincidence.

see also https://bbs.archlinux.org/viewtopic.php?pid=935211 for a topic about 100% CPU usage cause kded4.

Quote
(I think this kded is also known as kdeinit.) 
Or, the only other alternative is to not close kppp.

Yes, if you don't close kppp the kded4 is not created or maybe not bugged if created by other programs.

Quote
I think we are getting closer to what causes this.  Thanks again for the feedback, Sandro!
Lisa Marie

Thanks to you Lisa, best regards.
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #16 on: July 30, 2011, 20:32:43 PM »

Just a quick reply to confirm what you have asked me to check.

Just to clarify, when I log in, kppp dial out, surf.... disconnect, close kppp, my desktop is normal.  At least I think so (I am getting brain dead after so many reboots  Wink  )  It is when I start kppp again, connect, and while connect, if I click on programs like Package Manager, etc. they take forever to appear.  This time as you suggested when this slowness occurred, I opened up htop, selected kded4 which showed 92%CPU usage, and killed it.  As soon as it was killed, Package Manager appeared. Thanks for this tip!  Will have to fine tune this bug report, but not NetworkManger, but kded4 (equivelant to kded in KDE3.5.10).
Ciao, Lisa Marie
Logged
Sandro
Pardus fellow craft
**
Posts: 53



View Profile
« Reply #17 on: July 30, 2011, 21:11:12 PM »

Just a quick reply to confirm what you have asked me to check.

Just to clarify, when I log in, kppp dial out, surf.... disconnect, close kppp, my desktop is normal.  At least I think so (I am getting brain dead after so many reboots  Wink  )  It is when I start kppp again, connect, and while connect, if I click on programs like Package Manager, etc. they take forever to appear.  This time as you suggested when this slowness occurred, I opened up htop, selected kded4 which showed 92%CPU usage, and killed it.  As soon as it was killed, Package Manager appeared. Thanks for this tip!  Will have to fine tune this bug report, but not NetworkManger, but kded4 (equivelant to kded in KDE3.5.10).
Ciao, Lisa Marie

Tanks for the feedback. The kded4 problem is vastly, this comment shows a problem like mine:

«Bianca Kwey (biancakwey) wrote on 2011-05-05:    #8

I'm having this problem too. I'm connect with a mobile broadband; the problem with kded4 happen when I try to disconnect. In the cd live knetwork manager; in the installed system (kubuntu 11.04 32 bit) when I try to disconnect kppp. CPU to 100% (intel pentium 4 3,20 Ghz)»

And many other post here:

https://bugs.launchpad.net/ubuntu/+source/plasma-widget-networkmanagement/+bug/759209

http://kubuntuforums.net/forums/index.php?topic=3116537.0

ecc, ecc. http://www.google.com/search?q=kded4
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #18 on: July 30, 2011, 22:01:46 PM »

And thank you for the links.  I looked for these, but could not find anything.  I guess it was because I added the word "dialup" to search and not VPN, which would be more common these days. 

In the Kubuntu thread, they mention an upgrade to Natty.  I assume this was when KDE4 was upgraded to KDE4.6.5. 

I have since added Pardus 2011.1 64 bit testing repository to Package Manger.  I did all of the updates, about twelve, which included baselayout, but it didn't help.  I assume this problem is upstream and we will have to wait for an update to KDE4. 

I'm trying to figure out how to write up this bug.  I'll try to keep it simple and to the point.  Grin
P.S.  Have you tried disabling nepomuk in System Settings Dtrigi search?  Previous versions of Pardus this was not enabled upon installation. 
Logged
Sandro
Pardus fellow craft
**
Posts: 53



View Profile
« Reply #19 on: July 30, 2011, 23:00:39 PM »

I have since added Pardus 2011.1 64 bit testing repository to Package Manger.  I did all of the updates, about twelve, which included baselayout, but it didn't help. 
Interesting, i have only one packet to update kdelibs and then my pardus 2011.1 is up to date.

Quote
I assume this problem is upstream and we will have to wait for an update to KDE4.
I think so too  Sad((( Perhaps there is some tricky workaround for any single problem.

Someone has resolved setting:

«The workaround, at least for me, is to edit /usr/share/kde4/services/kded/networkstatus.desktop and set X-KDE-Kded-autoload=false and X-KDE-Kded-load-on-demand=false, restarting kded4 afterwards.»

I have tried it but without lucky.

Quote
I'm trying to figure out how to write up this bug.  I'll try to keep it simple and to the point.  Grin

https://bugs.kde.org/show_bug.cgi?id=220047

the bug is already written:

Code:
kded4 continually uses about 100% of one CPU core.  Here's the output of `top i':

top - 13:53:26 up  1:50,  2 users,  load average: 1.11, 1.40, 1.43
Tasks: 168 total,   2 running, 166 sleeping,   0 stopped,   0 zombie
Cpu(s):  1.2%us, 29.8%sy,  0.0%ni, 68.7%id,  0.0%wa,  0.1%hi,  0.2%si,  0.0%st
Mem:   1539740k total,  1525796k used,    13944k free,    29536k buffers
Swap: 20964784k total,    76060k used, 20888724k free,   589672k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 1425 msl       20   0  387m  13m 9444 R   95  0.9 103:54.75 kded4
 4670 msl       20   0 19132 1364  980 R    0  0.1   0:00.42 top

I'll also attach the output of sysprof.

This bug is a regression in KDE 4.4.  The virtual machine is an upgraded clone
of a KDE 4.3.4 virtual machine, which runs in an identical environment and does
not exhibit the same problem.

Let me take the opportunity to thank you for your hard work on KDE.

Tanks for the good job to all the KDE team the best Desktop manager Smiley

Quote
P.S.  Have you tried disabling nepomuk in System Settings Dtrigi search?  Previous versions of Pardus this was not enabled upon installation.

Yes it is disabled in my configuration:
Nepomuk/Strigi Server Configuration: Nepomuk system is inactive, strigi service not running.

It is my old configuration, i have not delete my old /home. But i had try to make a new user when i used P2011 (not dama dama) and the problem was remained.
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #20 on: July 31, 2011, 00:59:21 AM »

Interesting, i have only one packet to update kdelibs and then my pardus 2011.1 is up to date.

To add testing for 64 bit 2011.1 testing, open terminal:

Code:
sudo pisi ar pardus-2011.1-testing http://packages.pardus.org.tr/pardus/2011.1/testing/x86_64/pisi-index.xml.xz

I then open Package Manager GUI and under Settings>Configure>Repos I move testing to top and do an update.  I for one feel that Pardus testing repos are safe in my experience.  In other distros they can be problematic.

I'll have to point Pardus to that bug report you shared, just in case it helps them.  I too will try that Kubuntu fix that was mentioned.  Just to see if it helps, though it did not for you.
Regards, Lisa Marie
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #21 on: July 31, 2011, 20:23:17 PM »

Hello Sandro,

And still testing this to see if some service is causing this problem.

Do you have NetworkManager User Settings Service ticked  in KDE Service Manager  (System Services> Startup and Shutdown>Service Manager)?  If so, highlight this service and stop the service, click Apply.  Restart computer and see if you have more runaway CPU.

This happened again earlier today when my internet connection stalled and kppp died.  I waited a minute and reconnected, opened Htop process viewer and noticed that KDED4 was at top and showing 92%CPU usage, fluctuating to 50% then down to normal, and then back up again a few seconds later to 92%.  Not good for the CPU.  I let it go a bit and went tried to go to KDE Service Manager GUI and I got an error message, "Unable to contact KDED".  I then killed the user owned kded4 process and I was able once again to view Service Manager.
So far, after unticking this and rebooting, I have not had the problem, but it may be too soon to tell, so if you could try this, I would appreciate it.  By the way, I have all other settings normal, have changed back anything changed.  The only thing I do not have running is avahi
Code:
sudo /usr/sbin/avahi-daemon -k
I do this each time upon reboot because it starts automatically, even though I have it not to start up in system services.
I do not think it necessary for me to have it running.  Oh, and nepomuk is disabled, too.

I have read another bug report that could be part of the problem:
https://bugs.launchpad.net/ntrack/+bug/770390
I was going to try and uninstall this, but it is tied in with base system.  I see there is python-ntrack that can be installed. but don't know if installing this would help, but am curious to try.
Lisa Marie
P.S. I've attached image of KDE service manager, which is separate from System Services and much more a mystery to me as to what actually they are called.  They seem to be a part of kdelibs or kde4libs.
 Update:
I have to thank you for pointing me in the right direction.  The fix for editing networkstatus.desktop file worked for Corporate 2 problem I was having.  So, I edited this file in Pardus 2011.1 too, to see if it works.  I noticed that if I try to stop this service in the Service Manager GUI, it does not stop it from starting upon next reboot.  I guess it is because the GUI is run as user and not as super user or root.
Thanks again!
Lisa Marie


* kdeservicemanager.png (127.81 KB, 804x707 - viewed 241 times.)
« Last Edit: July 31, 2011, 23:34:37 PM by Lisa » Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #22 on: August 01, 2011, 17:03:59 PM »

Update:
I logged in today, and current setup is with nepomuk enabled and the networkstatus.desktop file changed to "false". 
Problem happened again.  What caused it is same thing that happened yesterday.  I was at a webpage too long and my internet connection died (kppp says ppp daemon died).  I opened Htop as I wanted to see if the CPU would spike.  kppp was still up and I reconnected.  At that point I saw the top process kded4 and CPU at 92% again, fluctuating to 60% then back up again.  I killed the process "sigkill". 
So, turning off networkstatus in that file did not work for me, either.

Interesting to see that when I first logged in and connected to internet, my speed was at 46666.  After killing kded4 my speed is back to what it normally is, 50666. 
Lisa Marie
Logged
John A
Guest
« Reply #23 on: August 01, 2011, 19:36:00 PM »

I don't know if Nepomuk did this problem. But I see a lot of issues with it:

http://kubuntuforums.net/forums/index.php?topic=3116715.0
http://chakra-project.org/bbs/viewtopic.php?id=2172

Will it be any difference if you disable it?
Logged
Sandro
Pardus fellow craft
**
Posts: 53



View Profile
« Reply #24 on: August 01, 2011, 20:08:34 PM »

Update:

I have try your suggestions but without luky Sad
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #25 on: August 01, 2011, 21:55:51 PM »

I don't know if Nepomuk did this problem. But I see a lot of issues with it:
Will it be any difference if you disable it?
Hi John A,
Thanks for those links!  Yes, I now have it disabled in both areas of System Settings: Desktop Search and under Startup and Shutdown>Service Manager.  When it happened earlier today, it was running.  Confusing to find out where all of these services are and how to turn them off.  Some of them don't easily turn off and only restart up again.  I also went ahead and stopped Status Notifier Manager, Network Status, Nepomuk Search Module and Network Manager User Settings Service under KDE Service Manager.  Also, avahi-daemon is killed for my own preferences.  
After a reboot, I  will test it by sitting too long at a web page, which will cause my connection to die.  At least I know what triggers it for my situation.  
And thanks for feedback, Sandro.  
Regards, Lisa Marie

Update after reboot: the good news is that my connection speed is normal (50666) with all of the above settings disabled or stopped. 

« Last Edit: August 01, 2011, 22:09:11 PM by Lisa » Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #26 on: August 02, 2011, 02:03:39 AM »

Well, nepomuk started again even with it disabled as mentioned above.  I then tried editing
/usr/share/kde4/services/kded/nepomuksearchmodule.desktop and setting the one true setting to false for autostart.  It still started up!  Arggh. I guess this is still a work in progress for KDE developers, but boy, I'm beginning to feel like I'm using Windows and getting the strange urge to look for third-party software with  names like:
Startup Service Killer
Asphyxiate Akonadi
Nuke Nepomuk
Demon Daemon Stalker
and
Abort Avahi
I'm at the point where I just want to open up Dolphin as root and untick all of those executables so they don't start in the first place.  I hope KDE team makes it easier to disable these.  I even went as far as to run systemsettings as root and try and stop the services that way, to no avail.   The good thing is I have Corporate 2 installed and it doesn't have these services installed and they are fairly easy to remove if I install them, as they are separate from KDE.
Lisa Marie
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #27 on: August 02, 2011, 04:28:20 AM »

Or, how about, Strigi Strangler.  OK.  Enough silliness.

Yes, John A, I think you narrowed down the problem.  Nepomuk and Akonadi.  I've already gone into Kontact and disabled all there because I don't use them, like Kmail, Calender, Journal, though I wouldn't mind using Knotes, but not as a part of Akonadi.  It seems more programs are getting sucked into akonadi.  Didn't knotes used to be its own program?

I actually did go into each of the bin files>permissions and untick them to make them nonexecutable, and that did work, but it was a hammer way of taking care of the problem. And,  Interesting that when I re-ticked each to make them executable, that was when my CPU started spiking again, so I'm pretty sure nepomuk and akonadi is what is causing the kded4 cpu spike problem and wired connection.

Here's what works so far for me.  I had to find a current fix because the previous disabling methods prior to KDE 4.6.5 do not work anymore.

Update:  the next day, testing persons' fix, and it failed.  Today my connection disconnected (pppd died) and all was well for a minute or two ( I could click on package manager, file manager,  shutdown or restart buttons with normal response time).  Then I clicked on "connect" in kppp, connected, and looked at Htop: 96%cpu kdedinit4: kded4 [kdeinit] appeared at top.  I killed it.  
I've read that certain versions of Soprano are thought to cause this problem.  So back to square one as to cause, but I can trigger it if I want if anyone wants me to test something, like maybe reverting to an earlier version of something.  
Lisa Marie




« Last Edit: August 02, 2011, 17:07:15 PM by Lisa » Logged
Sandro
Pardus fellow craft
**
Posts: 53



View Profile
« Reply #28 on: August 30, 2011, 15:38:15 PM »

Ok, i suppose i have find the trouble:

The problem in ntrack:

https://bugs.kde.org/show_bug.cgi?id=268038

ntrack 014 has a known issue that causes this infinite loop
(https://bugs.launchpad.net/ntrack/+bug/755608).  It will be fixed in ntrack
015.

http://old.nabble.com/Removed-ntrack-dependency-from-kdebase4-runtime-td32271148.html

Looks like ntrack caused us a lot of troubles and being an optional
dependency I removed it from build dependencies of kdebase4-runtime. If
it proves to be stable/useful again we can always add it back.

********

So the solution are two: cut ntrack or wait for ntrack 015. Pardus 2011.1 has the old ntrack 011:

# pisi info ntrack
Installed package:
Name                : ntrack, version: 0.011, release: 1

Logged
Sandro
Pardus fellow craft
**
Posts: 53



View Profile
« Reply #29 on: November 17, 2011, 19:08:04 PM »

I have see that Ntrack is be upgraded . Now i have kded working fine when i close kppp.
If it is all ok i tag this topic [Resolved].
Logged
Pages: 1 [2] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!