Welcome, Guest. Please login or register.
April 21, 2014, 16:43:14 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Bugs
| | |-+  kded4 hangs when disconnect/reconnect dial up - VPN, too [solved]
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] 2 Go Down Print
Author Topic: kded4 hangs when disconnect/reconnect dial up - VPN, too [solved]  (Read 3957 times)
Lisa
Pardus Guru
****
Posts: 841



View Profile
« on: July 31, 2011, 21:17:53 PM »

I didn't need to use a translator to figure out this bug title Cheesy
Bug 17765
« Last Edit: November 04, 2011, 19:41:25 PM by Lisa » Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #1 on: August 18, 2011, 22:00:58 PM »

Erol Saner recently added a comment to this bug and found a solution that works for him.  He uses KPPP, too.  The launchpad ubuntu bug goes further than what I did.  I did edit the file:
/usr/share/kde4/services/kded/networkstatus.desktop to "false" but an additional step to unload a module stated in reply #5.  I didn't do the latter.  Maybe Sandro can try this?   Red-faced as I can't try this.  I got rid of the installation and the disc as I felt sorry for my CPU. But, sounds like this bug is only in the 64 bit version.   
Lisa Marie
Logged
Sandro
Pardus fellow craft
**
Posts: 53



View Profile
« Reply #2 on: August 23, 2011, 14:30:08 PM »

Maybe Sandro can try this?   

Code:
There I set autoload and load-on-demand options to false:

X-KDE-Kded-autoload=false
X-KDE-Kded-load-on-demand=false

Then - unloaded the module manually
$ qdbus org.kde.kded /kded unloadModule networkstatus
and restarted kded4
$ qdbus org.kde.kded /kded quit
$ kded4 &

try it but without luky, restart and it is the same: don't works: when i stop internet connection in kppp kded4 goes to 100% cpu.
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #3 on: September 01, 2011, 21:07:07 PM »

Thanks for trying this, Sandro.  I appreciate the feedback.   
Regards, Lisa Marie
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #4 on: October 07, 2011, 19:35:12 PM »

Here's hoping an update will resolve this, as, a bit sad that after just installing 2011.2, and upon restart of system after initial install log in, I am getting the same problem with extreme CPU percentages with kdeinit4 after I disconnect from KPPP, and later reconnect with KPPP , which results in very slow response from any of the KDE programs, like Konqueror browser, and Dolphin file manager, and restart or shutdown.  (and that's a long grammar sentence)
Lisa Marie
Edited to clarify symptoms.
No updates yet for either stable or testing. 
« Last Edit: October 07, 2011, 20:33:03 PM by Lisa » Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #5 on: October 11, 2011, 05:40:31 AM »

Woo Hoo, I think it's solved. Think, because I'm a newbie at compiling in Pardus. I installed the build-essential packages from the Pardus wiki how-to
Code:
sudo pisi install -c system.devel
plus some extra devel. packages like
ntrack-devel.  I then installed ntrack-014.tar.gz I got from launchpad and long story short, I disconnected from KPPP, waited a few minutes and reconnected and brought up top in terminal, or htop gui equivalent, and the CPU is not racing high near 85 and 92%.  I will have to test this tomorrow. 
I do suspect it was the .so file in /usr/lib/ntrack/modules that was the culprit.  I decided to remove that .so file with ntrack version 011 and had no problems, either.  I think the file was ntrack-libnl1.so of version 011.
Lisa Marie
« Last Edit: October 19, 2011, 16:02:00 PM by Lisa » Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #6 on: October 11, 2011, 18:10:46 PM »

No, problem still exists. 
There are patches for this problem done by at least three people, Mr. Merry, Mr. Sack, and Mr. Kitterman and put in upstream for ubuntu.  I'll have to look up how to install a patch, or maybe I can suggest Pardus team to do it for me. 

Some relevant links that have probably already been posted at this forum:
https://bugs.launchpad.net/ntrack/+bug/755608

https://bugs.launchpad.net/ntrack/+bug/785119

http://www.linuxforums.org/articles/using-diff-and-patch_80.html

Back to drawing board.
Lisa Marie

« Last Edit: October 19, 2011, 15:58:33 PM by Lisa » Logged
Alexey
Pardus fellow craft
**
Gender: Male
Posts: 95



View Profile
« Reply #7 on: October 18, 2011, 04:16:36 AM »

To Lisa.

One user in the Russian community has a similar problem.  http://linuxforum.ru/viewtopic.php?id=16961

This bug http://bugs.pardus.org.tr/show_bug.cgi?id=19286

I understand correctly that the problem can be solved by removing ntrack?
Or need to apply patches, where these patches?
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #8 on: October 18, 2011, 17:51:04 PM »

Hi Alexey,
Yes, I had to remove ntrack files, which isn't the best way to solve a problem, but it worked for me.  I did a reinstall yesterday after playing with trying to compile ntrack-009, as I have read this version  of ntrack does not cause a problem.  I assume I compiled it correctly as the configure log didn't show any major errors.  If I did install it correctly, it worked without problems.

But, after reinstalling, I find the only files I have to remove are:
/usr/lib/libntrack.so
/usr/lib/libntrack.so.0
/usr/lib/libntrack.so.0.3.3

ntrack-qt4 files can be left alone as well, as they do not cause problem.  At first I thought they did.  I also left this file as it is:
 /usr/lib/ntrack/modules/ntracklibnl1.so , and no problem with it being left alone as well. 

There is a proposed patch was for ntrack - 011-1ubuntu1.1.  And this bug report has patches, but I'm not sure for what version?  https://bugs.launchpad.net/ntrack/+bug/785119
Lisa Marie
Logged
Alexey
Pardus fellow craft
**
Gender: Male
Posts: 95



View Profile
« Reply #9 on: October 18, 2011, 18:55:57 PM »

Milestone ntrack 015 but I think no problem if we apply it to 0.11
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #10 on: October 18, 2011, 22:44:18 PM »

So far, it seems these patches are working if I did the compile and patches correctly.  I went ahead and tried compiling ntrack-014 tar again, this time applying that ntrack-poll-fix.patch from Mr. Merry for the ntrack.c file, as well as the deadloop.patch from Mr. Sack for the ntrack-014/modules/ntrack-libnl.c~.

Here is my bash history:
Code:
cd Build
tar -xf ntrack-014.tar.gz
cd ntrack-014
cd common
patch ntrack.c < ntrack-poll-fix.patch
exit
cd Build
cd ntrack-014
cd modules
patch ntrack-libnl.c < deadloop.patch
exit
sudo mv ~/Build/ntrack-014 /usr/local
cd /usr/local/ntrack-014
PKG_CONFIG_PATH=/usr/lib/pkgconfig
export PKG_CONFIG_PATH
automake
./configure --help
./configure --prefix=/usr --without-glib2 --without-gobject --without-pygobject --without-qt4
make
sudo make install

I welcome any suggestions on compiling as I'm new at this. 
I did install the developement packages plus ntrack-devel.
I think it is working, because in my Pardus 2011.2 install earlier this week I tried compiling version 014 and had the same problem,  Not this time. 
P.S. I didn't delete the ntrack-011 files
/usr/lib/libntrack*  but moved them to my home directory and renamed them to sv_libntrack*.  I did the same with /usr/lib/ntrack/modules/ntracklibnl1.so.   to sv_ntrack/modules/ntrack-libnl1.so
Lisa Marie
Logged
Alexey
Pardus fellow craft
**
Gender: Male
Posts: 95



View Profile
« Reply #11 on: October 19, 2011, 02:55:20 AM »

There correctly steps: (sorry for my bad english)

in a modern linux does not need to manipulate with PKG_CONFIG_PATH

~ $ sudo pisi remove ntrack ntrack-qt4 --ignore-dependency
~ $ sudo pisi install libnl-devel qt-devel gobject-introspection-devel python-pygobject-devel

see https://svn.pardus.org.tr/pardus/2011/testing/network/misc/ntrack/pspec.xml <BuildDependencies>

~ $ mkdir temp && cd temp
temp $ wget http://launchpad.net/ntrack/main/014/+download/ntrack-014.tar.gz
temp $ tar xf ntrack-014.tar.gz
temp $ cd ntrack-014/
ntrack-014 $ wget https://launchpadlibrarian.net/68805103/deadloop.patch
ntrack-014 $ patch -p0 < deadloop.patch
ntrack-014 $ wget https://launchpadlibrarian.net/72003798/ntrack-poll-fix.diff
ntrack-014 $ patch -p0 < ntrack-poll-fix.diff
ntrack-014 $ ./configure --disable-static --prefix=/usr
ntrack-014 $ make -j4
ntrack-014 $ sudo make install

If you need original pardus ntrack and ntrack-qt4 just: sudo pisi install --reinstall ntrack ntrack-qt4



http://bugs.pardus.org.tr/show_bug.cgi?id=19286 Smiley
« Last Edit: October 19, 2011, 03:10:32 AM by Alexey » Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #12 on: October 19, 2011, 15:54:37 PM »

Alexey, you are wonderful!  Those are the tips I wanted to know as I was going about this in the dark, picking up information from here and there on the internet of others trying to compile a linux tar file. 
I also did not know one could force PiSi to remove a package without it wanting to grab the dependencies as well.  This will be much better way than manually deleting default files.  I seem to always find the difficult way to do things.  That's what I get for not asking.

The two patches for ntrack-014 work fine.  But, I wanted to find out if the patches worked in 011 version that is installed in Pardus.  The ntrack-poll-fix.patch wasn't needed, but the deadloop.patch worked and I am not having problems:
Code:
me@pard2011 ~ $ cd Build
me@pard2011 Build $ tar -xf ntrack-011.tar.gz
me@pard2011 Build $ cd ntrack-011/modules
me@pard2011 modules $ patch ntrack-libnl.c < deadloop.patch
patching file ntrack-libnl.c
Hunk #1 succeeded at 374 (offset -1 lines).
Hunk #2 succeeded at 384 (offset -1 lines).
me@pard2011 modules $

You are a great help, and you have given me confidence in trying this in the future.  Next step is to understand creating PiSi package.  I'll let the Pardus team know about the patch.
Thank you for helping me with this!
Kind regards, Lisa Marie
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #13 on: October 19, 2011, 19:40:22 PM »

I wanted to try Alexey's correct method of compiling in Pardus, so...I reinstalled Pardus 2011.2 x86_64.  This is fairly easy as I now keep PiSi packages cached on an external hard drive, so after reinstalling, it is as quick as lightning to retrieve and install updates. 

The only thing different is I wget the ntrack-011 version, since ntrack-qt4-011 is not causing any problems and I wanted to work with the default Pardus ntrack version.
Code:
me@a8ne64_oct temp $ cd ntrack-011
me@a8ne64_oct ntrack-011 $ patch -p0 < deadloop.patch
patching file modules/ntrack-libnl.c
Hunk #1 succeeded at 374 (offset -1 lines).
Hunk #2 succeeded at 384 (offset -1 lines).
me@a8ne64_oct ntrack-011 $ ./configure --disable-static --prefix=/usr --without-glib2 --without-gobject --without-pygobject --without-qt4
as you can see, I installed without glib2, gobject, pygobject and qt4 because the first three are by default, not installed in Pardus, and the last is already installed and does not cause problem.  If I should have done these extras, let me know.  Thanks!
I've got tracking enabled in under System>Startup and Shutdown>Service Manager.  The only two services I don't have running are synaptiks and Bluedevil as I don't use these types of hardware.  So, restarted computer, connected, disconnected, connected and disconnected again and so far no racing CPU. 
Now can I say, Woo Hoo?  Grin
Again, thanks Alexey!
Lisa Marie
Logged
Alexey
Pardus fellow craft
**
Gender: Male
Posts: 95



View Profile
« Reply #14 on: October 19, 2011, 23:09:51 PM »

I can also check the load kded.

I use wi-fi module ath9k.
And if before when connected to the internet, I unloaded module modprobe-r ath9k and kded loaded to 100%
But after patching everything is fine.
Logged
Pages: [1] 2 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!