Welcome, Guest. Please login or register.
April 19, 2014, 03:51:35 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Software
| | |-+  SABnzbd
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: 1 [2] 3 Go Down Print
Author Topic: SABnzbd  (Read 4809 times)
owiknowi
Guest
« Reply #15 on: October 06, 2011, 18:31:27 PM »

@gyan000
reading your helpful suggestions, i take it you download .nzb files directly with sabnzbd? you don't use a gui like lottanzb?
leaves me with two questions, if i may:
- how do you add a .nzb file to a download queue? through the 127.0.0.1:8080 web address and interface?
- and can i use a ssl pay server on port 563, which i can add to the .ini file, this way?

these questions came up whilst lottanzb showed no activity at all, claimed not to support the sabnzbd version present, and meanwhile the added .nzb still was downloaded (a 19 mb gpl manual)!
this is weird stuff to me, i like to understand a bit what my computer is doing behind my back.  Huh?
« Last Edit: October 06, 2011, 18:33:19 PM by owiknowi » Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #16 on: October 06, 2011, 18:32:59 PM »

Just to inform you.
a.palius is from Poland and canĀ“t read/speak the German language.
So I had to more-or-less translate for him.
Logged
owiknowi
Guest
« Reply #17 on: October 06, 2011, 18:35:52 PM »

@atolboo
thanks for your effort and information, i will address a.palius in english.
Logged
gyan000
Pardus fellow craft
**
Posts: 46



View Profile WWW
« Reply #18 on: October 06, 2011, 19:38:44 PM »

First of all,  you _just_ need to configure sabnzbd.config.


Below, for example, my /etc/sabnzbd.config, needed by the service SABnzbd. (using ssl)

Code:
# SABnzbd should read the config file of this user. (/home/USERNAME/.sabnzbd/sabnzbd.ini)
USERNAME="gyan011"

# SABnzbd need login/password ? (needed for shutdown)
LOGIN="gyan000"
PASSWORD="blahblah"

# Default http port.
PORT="8080"

# SABnzbd configured to use SSL ?
USE_SSL="true"

# Default https port
PORT_SSL="9090"

This file configured, it's the web interface (for me it's https://localhost:9090/ if I use it at home) of SABnzbd that will create and configure the ~/.sabnzbd/sabnzbd.ini & co. So before the first use of SABNzbd, delete your directory ~/.sabnzbd/
You do not have to edit yourself ~/.sabnzbd/sabnzbd.ini
So I'm using the web interface to configure ( https://localhost:9090/config/ ) all I want.
For example, for .nzb files, I simply saved them in a 'dl' directory. And SABnzbd check regulary if there are new .nzb files to download. If so, it start automatically the download.
When you use for the first time SABnzbd, so the ~/.sabnzbdi/* is not configured, the web interface let you configure the language, usenet servers to use etc.
I'm doing all my downloads with this web interface that is very well made.
Logged

---
gyan000 - plus-qu'en-retard
owiknowi
Guest
« Reply #19 on: October 08, 2011, 10:17:48 AM »

 Embarrassed sorry for my late response gyan000!
as soon as i get the computer i use for these things up and running again, i'll follow your instructions and post the result!

thank you again for your effort,

owiknowi
Logged
owiknowi
Guest
« Reply #20 on: October 10, 2011, 13:17:30 PM »


almost embarrassing to let you know, after all your explicit help, which i followed to the letter, it still won't work.
the service sabnzbd can't be started (marked to start at boot). but even a manual start as admin/root won't do the trick.

took a look at a ubuntu 10.10 install whith lottanzb (by default in its repo), and there it uses hellananzb as a backend.
just start lottanzb, fill in requested data, and there it goes. but that's all gnome based.

my uneducated guess is that maybe sabnzbd and lottanzb on pardus 2011.2_32 just don't quite agree with each other?

so, i will post more about this where i first started (wish list).

thanks again for your effort, it's really much appreciated! _O_

owiknowi
Logged
owiknowi
Guest
« Reply #21 on: October 11, 2011, 12:01:26 PM »

@moderator/pardus chief
should i continue this here? or at the wish list (package is still not working)?
_O_
Logged
owiknowi
Guest
« Reply #22 on: October 13, 2011, 09:31:59 AM »

installed sabnzbd -without lottanzb- on a fresh installed 2011.2_32 us. followed gyan000's instructions again and this time  i got the web interface (choose language page 1/4).

the service could only be started from terminal. although the service is added to the listed services, it doesn't seem to do much there. Huh?

could set up a server, add a .nzb file, all still without lottanzb. only, minor, thing was the download wouldn't start...   

will take a look at that later. also will install the lottanzb front-end, although it looks like it's not really needed here?
that would be a big sorry from me to the packager...  but, will first try both.
Logged
gyan000
Pardus fellow craft
**
Posts: 46



View Profile WWW
« Reply #23 on: October 28, 2011, 22:18:52 PM »

I would like to know if it is possible to update this package since the version 0.6.10 is now available.
Thanks !
Logged

---
gyan000 - plus-qu'en-retard
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #24 on: October 29, 2011, 00:51:43 AM »

.....to update this package .....
I will have a at this package tomorrow.
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #25 on: October 29, 2011, 11:04:02 AM »

Version 0.6.10 is now available as update
Logged
gyan000
Pardus fellow craft
**
Posts: 46



View Profile WWW
« Reply #26 on: October 29, 2011, 11:17:55 AM »

And SABnzbd works perfectly fine.  Smiley
Thanks for your great work and reactivity atolboo !
Logged

---
gyan000 - plus-qu'en-retard
gyan000
Pardus fellow craft
**
Posts: 46



View Profile WWW
« Reply #27 on: December 29, 2011, 19:32:43 PM »

I would like to know if it is possible to update this package since the version 0.6.14 is now available.
Thanks !

Note:
No, it's not a copy-paste from a previous post.  Grin
Logged

---
gyan000 - plus-qu'en-retard
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #28 on: December 29, 2011, 20:45:41 PM »

Is on the list after Qgis
And you can already try it for yourself by these build files
« Last Edit: December 29, 2011, 20:49:59 PM by atolboo » Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #29 on: December 30, 2011, 23:06:27 PM »

the version 0.6.14
And now available (also as update)
Logged
Pages: 1 [2] 3 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!