Welcome, Guest. Please login or register.
April 24, 2014, 22:56:12 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Software
| | |-+  Google+ Hangouts: also working in Pardus 2011
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: 1 [2] 3 4 5 Go Down Print
Author Topic: Google+ Hangouts: also working in Pardus 2011  (Read 7489 times)
pardus721
Guest
« Reply #15 on: November 23, 2011, 17:01:46 PM »

After studying Bug 14061, I decided not to try to build it.
This has a number of reasons.
1. These people are much better (as professionals) than I am as an amateur.
2. I don't want to interfere with their work.
3. When 32-bit libraries are required for the x86_64 version, it's Pardus-TR who should provide then.
This because it can have consequences for the system as a whole.
And it's a pity that after Comment 16 it's Turkish.
That doesn't improve readability.
http://translate.google.com/ isn't too bright in TR>EN translations.



Michiel is he a member of Turkish Pardus team ?

I recommend :
Wait than Pardus resolve the Bug 14061.
or
Demand at Google to create in collaboration with Pardus, a package.
or
Switch to ubuntu  Grin
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #16 on: November 23, 2011, 17:47:45 PM »

Michiel is he a member of Turkish Pardus team ?
No, he has no connection with Pardus in any way.
« Last Edit: November 23, 2011, 19:33:43 PM by atolboo » Logged
pardus721
Guest
« Reply #17 on: November 23, 2011, 18:20:29 PM »

Michiel is he a member of Turkish Pardus team ?
No, he has is no connection to Pardus in any way.

Thanks.
I was in confusion because there as a Michael in Planet Pardus and by the title "Administrator
Pardus Guru".
« Last Edit: November 23, 2011, 22:11:47 PM by pardus721 » Logged
Kranthi
Pardus fellow craft
**
Gender: Male
Posts: 102



View Profile WWW
« Reply #18 on: November 28, 2011, 12:11:07 PM »

I tried this
For 32 bit Users:

1 - sudo pisi bi https://svn.pardus.org.tr/pardus/playground/fatih.arslan/2011/google_talk/libpng12/pspec.xml
  Three packages (libpng12, libpng12-devel, libpng12-32bit) must be installed.
but got
Unsatisfied Build Dependencies: zlib-32bit
DEBUG: PackageDB initialized in 0.0873718261719.
Program terminated.
Build dependency zlib-32bit cannot be satisfied

I couldn't find the Devel repo address in the forums, Can you please direct me to it?
Thanks in advance.  Smiley
Logged

The Cube
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #19 on: November 28, 2011, 12:58:25 PM »

Can you please direct me to it?
Overview of software sources for Package Manager of Pardus 2011 and 2011.1.
And replace /stable/ by /devel/ Wink
Logged
Kranthi
Pardus fellow craft
**
Gender: Male
Posts: 102



View Profile WWW
« Reply #20 on: November 28, 2011, 14:35:03 PM »

now, still, i get the message
DEBUG: RepoDB initialized in 0.000358819961548.
Safety switch: the component system.devel cannot be found
DEBUG: InstallDB initialized in 0.0191400051117.                                                                                                                 
Unsatisfied Build Dependencies: zlib-32bit
DEBUG: PackageDB initialized in 0.000257968902588.
Program terminated.
Build dependency zlib-32bit cannot be satisfied

And i got a new error, Safety switch: the component system.devel cannot be found.
I thought that i would be able to install zlib-32bit without activating the Devel repo.
is this possible?
Logged

The Cube
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #21 on: November 28, 2011, 16:47:18 PM »

activating the Devel repo.
is this possible?
Yes, you don't have to activate the Devel repo. And it's also not recommended to do that.

Just install (without activating Devel repo in Package Manager) the package zlib-32bit from Devel repo.
That's a fundamental difference.
Logged
Kranthi
Pardus fellow craft
**
Gender: Male
Posts: 102



View Profile WWW
« Reply #22 on: November 28, 2011, 17:06:48 PM »

How do i do it?
I used
Code:
sudo pisi it zlib-32bit
I get
System error. Program terminated.
Repo item zlib-32bit not found

I don't get it.
Now if i do
Code:
sudo pisi bi https://svn.pardus.org.tr/pardus/playground/fatih.arslan/2011/google_talk/libpng12/pspec.xml
I get
DEBUG: InstallDB initialized in 0.0206501483917.
Safety switch: system.devel is already installed
Unsatisfied Build Dependencies: zlib-32bit
DEBUG: PackageDB initialized in 0.0878350734711.
Program terminated.
Build dependency zlib-32bit cannot be satisfied

Now the Safety switch: system.devel problem is not showing up. And I haven't done anything at all.
Logged

The Cube
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #23 on: November 28, 2011, 20:50:02 PM »

How do i do it?
I used
Code:
sudo pisi it zlib-32bit
I get
System error. Program terminated.
Repo item zlib-32bit not found

I don't get it.
This ^^^ is 100% correct.
Do you have a l686 or x86_64 system.
In other words, what is the result of
Code:
pisi lr
Huh?    And from the answer/result I can detect which system you have and can give further instructions.

And I also very much doubt whether these instructions from nkoc are 100% OK.
For instance: "For 32 bit Users:" and "libpng12-32bit" do not go together.

Now the Safety switch: system.devel problem is not showing up. And I haven't done anything at all.
This ^^^ isn't 100% correct as I also can Safety switch: system.devel is already installed
And system.devel is only a number ~100 packages which should be installed before a "pisi bi" can be successful.
On top of this there are (can be) an number of additional <BuildDependencies> (listed in pspec.xml) packages  for a successful build of the package.
« Last Edit: November 28, 2011, 21:07:49 PM by atolboo » Logged
Kranthi
Pardus fellow craft
**
Gender: Male
Posts: 102



View Profile WWW
« Reply #24 on: November 29, 2011, 04:49:49 AM »

Code:
pisi lr
pardus [active]
   http://packages.pardus.org.tr/pardus/2011/stable/i686/pisi-index.xml.xz
pardus user [active]
   http://pakete.pardususer.de/pardus-2011/i686/pisi-index.xml.xz
testing [inactive]
   http://paketler.pardus.org.tr/pardus/2011/testing/i686/pisi-index.xml.xz
devel [inactive]
   http://packages.pardus.org.tr/pardus/2011/devel/i686/pisi-index.xml.xz


safety switch most of the times is ok. But that was the one time when it showed an error i reckon. It's ok now.
Logged

The Cube
nkoc
Pardus fellow craft
**
Posts: 41


View Profile
« Reply #25 on: November 29, 2011, 10:14:32 AM »

hallo Kranthi,

1- sudo pisi dr pardus
2- sudo pisi er devel
3- sudo pisi up
4- sudo pisi it -c system.devel
5- sudo pisi bi https://svn.pardus.org.tr/pardus/playground/fatih.arslan/2011/google_talk/libpng12/pspec.xml
6- sudo pisi it libpng12-1.2.44-1-p11-i686.pisi libpng12-devel-1.2.44-1-p11-i686.pisi
   (or install with doubleclick on packages )
7- sudo pisi bi https://svn.pardus.org.tr/pardus/playground/fatih.arslan/2011/google_talk/google-talkplugin-i686/pspec.xml
8- then install with doubleclick on package google-talkplugin-2.1.7.0-1-p11-i686.pisi
9- test it with google-hangout
« Last Edit: November 29, 2011, 10:26:27 AM by nkoc » Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #26 on: November 29, 2011, 13:15:53 PM »

Are you very sure about your 9 commands
Because I get:
Quote
atolboo@pardus2011 ~ $ sudo pisi bi https://svn.pardus.org.tr/pardus/playground/fatih.arslan/2011/google_talk/libpng12/pspec.xml -y
pspec.xml                      (3.0 KB)100%     35.10 MB/s [00:00:00] [complete]
actions.py                     (1.0 KB)100%     16.75 MB/s [00:00:00] [complete]
DEBUG: ComponentDB initialized in 0.0056459903717.
DEBUG: RepoDB initialized in 0.000124931335449.
DEBUG: InstallDB initialized in 0.00565099716187.
Unsatisfied Build Dependencies: zlib-32bit
DEBUG: PackageDB initialized in 0.0507700443268.
Program terminated.
Build dependency zlib-32bit cannot be satisfied
                                                                                                         
Please use 'pisi help' for general help.                                                                                                                  
atolboo@pardus2011 ~ $
and
Quote
My continues and I guess is that there is an error in the build files for libpng12.
« Last Edit: November 29, 2011, 14:21:41 PM by atolboo » Logged
Kranthi
Pardus fellow craft
**
Gender: Male
Posts: 102



View Profile WWW
« Reply #27 on: November 29, 2011, 14:46:15 PM »

Yes, me too. Same error again.
user@system ~ % sudo pisi dr pardus
Password:
user@system ~ % sudo pisi er devel
devel repository needs to be updated
devel repository needs to be updated
devel repository needs to be updated
devel repository needs to be updated
user@system ~ % sudo pisi up
Updating repositories
Updating repository: pardus user
pisi-index.xml.xz.sha1sum      (40.0  B)100%    325.73 KB/s [00:00:00] [complete]
pardus user repository information is up-to-date.
Updating repository: devel
pisi-index.xml.xz.sha1sum      (40.0  B)100%    369.01 KB/s [00:00:00] [complete]
pisi-index.xml.xz              (1.5 MB)100%     72.25 KB/s [00:00:00] [complete]
No signature found for http://packages.pardus.org.tr/pardus/2011/devel/i686/pisi-index.xml.xz
* Package database updated.
Safety switch forces the upgrade of following packages:
glib2  libxml2  pisi  wireless-tools
The following packages will be upgraded:
NetworkManager                     NetworkManager-devel          SuiteSparse                  UNetbootin                     alsa-headers           
babl                               babl-devel                    c-ares                       c-ares-devel                   c-ares-docs             
cairo                              cairo-devel                   ccache                       chromium-browser               clementine             
digikam                            digikam-devel                 djview4                      djvu-plugin                    espeak                 
espeak-devel                       firefox                       flashplugin                  gdk-pixbuf                     gdk-pixbuf-devel       
gdk-pixbuf-docs                    gegl                          gegl-devel                   giflib                         giflib-devel           
gimp                               gimp-devel                    glib2                        glib2-devel                    glitz                   
glitz-devel                        gobject-introspection         gobject-introspection-devel  googletest                     googletest-devel       
gtk2                               gtk2-demo                     gtk2-devel                   gtk2-docs                      iproute2               
iptables                           iptables-devel                iso-codes                    jasper                         jasper-devel           
jasper-docs                        kde-wacom-tablet              kdebase                      kdebase-devel                  kdelibs                 
kdelibs-devel                      kdevelop                      kdevelop-devel               kdevelop-l10n-en_GB            knights                 
krename                            libgpod                       libgpod-devel                libimobiledevice               libimobiledevice-devel 
libmediainfo                       libnfnetlink                  libtalloc                    libtalloc-devel                libva                   
libva-devel                        libvdpau                      libvdpau-devel               libxml2                        libxml2-devel           
libxml2-docs                       libzen                        mediainfo                    mercurial                      mesa                   
mesa-devel                         metis                         module-alsa-driver           module-alsa-driver-userspace   module-virtualbox-guest
module-virtualbox-guest-userspace  nss                           nss-devel                    ntop                           openbox                 
openbox-devel                      pango                         pango-devel                  pango-docs                     phonon-backend-gstreamer
phonon-backend-xine                pisi                          pixman                       pixman-devel                   plymouth               
plymouth-core-libs                 plymouth-devel                plymouth-graphics-libs       plymouth-plugin-fade-throbber  plymouth-plugin-label   
plymouth-plugin-script             plymouth-plugin-space-flares  plymouth-plugin-throbgress   plymouth-plugin-two-step       plymouth-renderer-x11   
plymouth-theme-charge              plymouth-theme-fade-in        plymouth-theme-pardus        plymouth-theme-script          plymouth-theme-solar   
plymouth-theme-spinfinity          plymouth-utils                podofo                       podofo-devel                   powertop               
python-feedparser                  python-httplib2               python-libgpod               python-pyparsing               python-qt               
python-qt-devel                    python-qt-docs                python-qt-phonon             python-qt-webkit               quickformat             
scribus                            scribus-devel                 scribus-docs                 shared-mime-info               sip                     
sip-devel                          smplayer                      strigi                       strigi-common                  strigi-devel           
strigi-libs                        suspend                       texlive-bin                  timidity                       upower                 
virtualbox-guest-utils             wireless-tools                wireless-tools-devel         wpa_supplicant                 xcb-util               
xcb-util-devel                     xorg-video-openchrome       
Total size of package(s): 143.22 MB
There are extra packages due to dependencies.
Do you want to continue? (yes/no)y                                                                                                                               
Downloading 1 / 152

Now, i think i have updated my system with all unstable dev versions. So I'm expecting much more problems from the next time i restart. am i right?
« Last Edit: November 29, 2011, 14:50:39 PM by Kranthi » Logged

The Cube
Kranthi
Pardus fellow craft
**
Gender: Male
Posts: 102



View Profile WWW
« Reply #28 on: November 29, 2011, 14:59:08 PM »

I've also tried to install the zlib-32bit separately, but it was not found.
Logged

The Cube
Kranthi
Pardus fellow craft
**
Gender: Male
Posts: 102



View Profile WWW
« Reply #29 on: November 29, 2011, 15:06:36 PM »

I've restarted the system and the INTERNET is working properly. lol.
Logged

The Cube
Pages: 1 [2] 3 4 5 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!