Welcome, Guest. Please login or register.
April 20, 2014, 08:19:04 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Bugs
| | |-+  Corporate 2 installation, now I have an unknown virtual user
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Corporate 2 installation, now I have an unknown virtual user  (Read 1435 times)
Lisa
Pardus Guru
****
Posts: 841



View Profile
« on: December 23, 2011, 18:07:35 PM »

Hi all,

In past week I reinstalled Pardus Corporate 2 which the previous install had not been booted into for a month.  Anyway, after re-install and doing all updates I had a virtual user that showed up in boot log.  

Yesterday I reinstalled OS, and before doing any updates, that "udev...virtualbox user unknown" (not the exact wording) was there in boot log again.  And, I have an additional virtual device when I do the following:
Code:
ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:15:F2:17:31:A8
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:23 Base address:0x4000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:240 (240.0 b)  TX bytes:240 (240.0 b)

ppp0      Link encap:Point-to-Point Protocol
          inet addr:4.225.173.32  P-t-P:209.247.21.49  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:2321 errors:1 dropped:0 overruns:0 frame:0
          TX packets:2061 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:2295409 (2.1 Mb)  TX bytes:222740 (217.5 Kb)

virbr0    Link encap:Ethernet  HWaddr 0E:81:6D:AA:96:83
          inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:4049 (3.9 Kb)

I looked for packages with word "virtual" and removed them,:
Code:
Operation #8: remove
Date: 2011-12-23 10:37

    * virt-manager 0.8.6-6-c2-i686 is removed.
    * virtinst 0.500.5-8-c2-i686 is removed.
    * virt-viewer 0.2.1-4-c2-i686 is removed.

Operation #7: remove
Date: 2011-12-23 10:36

    * module-virtualbox-guest-userspace 4.0.2-31-c2-i686 is removed.
    * module-virtualbox-guest 4.0.2-31-c2-i686 is removed.

Operation #6: remove
Date: 2011-12-23 10:32

    * virtualbox-guest-utils 4.0.2-54-c2-i686 is removed.

And now I no longer get the unknown virtual box user in boot log, but I still have that interface in ifconfig.  Is there any other package I can remove for this?  I don't know what virbr0 is a part of, but obviously it means "virtual box".  I will need to report this as a bug in Corporate 2 as I don't know why it installed a virtual user.  Maybe it was because I had lan (ethernet) disabled in BIOS during installation, as I don't use it since I use dial up.  Normally I leave it enabled during installation of operating systems just to make NetworkManager happy, even though I don't use such a connection.  Argghh NM!

Thanks for checking on this!
Lisa Marie

P.S.  I wonder if this virtual user was created because this time I did not install Grub for Corporate 2?  Thinking aloud.


« Last Edit: December 23, 2011, 21:05:51 PM by Lisa » Logged
owiknowi
Guest
« Reply #1 on: December 25, 2011, 21:36:26 PM »

beats me, again, but i have a fresh un-updated kurumsal 2 still hanging around somewhere on my pc.
will update it and see what happens and post any interesting result back here.

maybe it has to do with an other os where a vm is installed?

and you didn't install grub? did you use another bootloader instead or just installed it into the / partition? i usually do the latter cause of the mob of installed penguins.
Logged
owiknowi
Guest
« Reply #2 on: December 26, 2011, 08:30:46 AM »

hi lisa marie,

just updated my -more or less default- kurumsal 2_64 installation. no notable strange changes as far as i can see.
first user, created during installation, starts at id 1000. next user i've created, for daily use without admin privileges, i've given a higher id-number.

only unknown 'user' is called nobody, with id 65534. but i think this is meant as a closing (highest) id.

i've used the default iso for kurumsal 2_64 (dated feb 2011) and installed grub on the system partition (not into the mbr).
did you perhaps install kurumsal from a virtual box within another penguin?
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #3 on: December 29, 2011, 01:05:55 AM »

Thanks so much for the feedback,owiknowi.  I did reinstall just to test, and this time installed 32 bit version Corporate 2 Grub to MBR which is what I normally do, and once again, there in boot.log is:

Code:
0m Starting udev
udevd[220]: specified user 'vboxadd' unknown
which I can get rid of by removing the virtual packages I mentioned above.  I was just surprised that the virtual packages were installed to begin with.  The only other thing different in the past two weeks is I have Windows 8 devel installed on my sda, second partition, which is a real partition and not virtual or logical.  Beats me as to what it is.  It doesn't seem to cause any problems or slow downs for me. 
Lisa Marie
Logged
owiknowi
Guest
« Reply #4 on: December 29, 2011, 08:15:35 AM »

hi lisa marie,

i have the following partitioning scheme on this pc:
sda1 (boot flag), w7 (64)
sda2 pardus 2011 (64)
sda3 pardus 2011 (32)
sda4 - extended -
sda5 - sda9 logical volumes with several penguins and kurumsal 2 (64) on sda9
all bootloaders installed on their system partitions (manage them through easybcd for windos)

so, my uneducated guess would be that w8 might have something to do with it? maybe it's got another build in feature to help us all benefit more from their bunk? like that mbr security thingy?

to rule out several options it would be nice if you could do a sole install of kurumsal on your pc, just to see what happens.
but i think in that case nothing strange will occur...

please let me know if i can be of any help (don't have w8 though).

owiknowi
duke of everything below zero kelvin  Wink
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #5 on: December 31, 2011, 19:09:57 PM »

Good ideas, owiknowi.  I didn't do a sole install, but I did install 32 bit version on my older PC that has XP on it, too.  The same situation occurred.  I'm going to mark this solved and assume this is just how this version installs with the virtual stuff as default.  I've only been using the 32 bit version for about 2 months and never did check the boot log or the output of iconfig.  The virtual user entry was probably there all along.  It was only recently that I noticed it.  I was able to also remove the virbr0 entry in ifconfig by going to the Virtual Machine Manager GUI (lo and behold!) and there is where I found virbr0 and disabled it and deleted it.  I was having problems with Corporate 2 64 bit version with kppp and kded crashing when I disconnected my internet connection, which is why I am using the 32 bit version, as it doesn't (seem) to happen. 

Beautiful day out for this time of year.  Time to wash the car.
Lisa Marie
Logged
owiknowi
Guest
« Reply #6 on: December 31, 2011, 19:41:00 PM »

afaik 32 bits os is still to be preferred over the 64 bit versions. that is, as long as you don't have any hardware that requires a 64 bit os (like more then 3gb ram and undoubtedly there's some more stuff i don't know about).

on the german pardus forum, a pretty skilled member called linuxfanatic, ones explained that one of the 'flaws' in 64 bits os, are the libraries for 32 bit support. like for older software and other compatibility issues.

so, imho, a 32 bit os is often more stable and most bugs are gone or known. i only use 64 bit on a pc with 8gb ram and no swap partition. just because i can... Grin
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!