Welcome, Guest. Please login or register.
April 20, 2014, 20:29:41 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Hardware
| | |-+  [SOLVED]Changed keyboard layout, now the keyboard doesn't work anymore -- at all
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: [SOLVED]Changed keyboard layout, now the keyboard doesn't work anymore -- at all  (Read 1504 times)
Aero9000
Newbie
*
Posts: 14


View Profile
« on: December 26, 2011, 16:55:04 PM »

Hi folks,

I screwed up my Pardus 2011 and I need some help in unscrewing it Smiley.  I wanted to type a special character and I realized my keyboard wasn't set for handling international characters (for example, an "e" with two dots on top). So I changed to keyboard layout to PC 105 Intl. After I rebooted I can no longer type anything. In fact, I can't even log on because the keyboard is completely dead -- even the num-lock, caps-lock etc. keys don't work anymore. (Obviously the keyboard itself is OK, as I am typing this using the same keyboard.)

Which files do I have to change in order to undo the damage? I am still able to access the install partition.

Second, what do I have to do to be able to type an international character?


Thanks.
« Last Edit: December 26, 2011, 20:59:03 PM by Aero9000 » Logged
owiknowi
Guest
« Reply #1 on: December 26, 2011, 17:55:23 PM »

you probably still can access 'system settings' / 'input devices', then first go to 'keyboard' 'keyboard model' (probably generic 101-key pc or 105-key pc)

next go to the second tab 'layouts' and check the box 'configure layouts' and add a new layout.
set your keyboard to the proper settings for your locale (like e.g.: us, english (us), international with dead keys).

the last two lines of this post describe the same: http://worldforum.pardus-linux.nl/index.php?topic=4090.msg21821#msg21821
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #2 on: December 26, 2011, 19:07:48 PM »

I am still able to access the install partition.
What do you mean by "install partition" Huh?

Second, what do I have to do to be able to type an international character?
I always use  KCharSelect and is available in KMenu > Utilities
In KCharSelec I use European Alphabets and Latin-1 Supplement.
« Last Edit: December 26, 2011, 19:14:43 PM by atolboo » Logged
Aero9000
Newbie
*
Posts: 14


View Profile
« Reply #3 on: December 26, 2011, 21:11:18 PM »

With your help I managed to fix it and here's how (short version  Wink).

When I got at the log on screen, using the mouse I selected command line for session type. I then logged in as root. Once I was in, I type "startx" to get a desktop. Then I followed owiknowi's hint to change the keyboard type and layout to the correct ones. I checked "Save settings system wide" and applied. It appears this last step was required in order to get the keyboard to work again.

Thanks y'all!
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #4 on: December 26, 2011, 22:19:47 PM »

In fact, I can't even log on because the keyboard is completely dead -- even the num-lock, caps-lock etc. keys don't work anymore.
and
Once I was in, I type "startx" to get a desktop.
do not fit together    (I was figuring out a solution wthout a keyboard)
Logged
Aero9000
Newbie
*
Posts: 14


View Profile
« Reply #5 on: December 27, 2011, 06:37:14 AM »

The problem was that the keyboard was dead once I got to the GUI log on screen. Because nothing worked I could not enter the password or escape from the GUI by using the keyboard (CTRL+ALT+F1, F2, F3, etc. didn't work either). However, in the lower left left corner you have options to choose a session type -- with the mouse. There I chose "command line". Once I selected that option, the GUI was terminated and I got to a terminal, where I was able to log on because here the keyboard did work. Once logged on to the terminal as root I typed "startx" to get to the desktop (because I was already logged on, I didn't have to re-enter the password). At the desktop once again the keyboard was dead. But with the mouse I was able to enter the settings menu and make the changes you proposed.
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #6 on: December 27, 2011, 08:48:51 AM »

  for the explanation.
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!