Welcome, Guest. Please login or register.
April 18, 2014, 12:46:01 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Hardware
| | |-+  permanent symlink created for /dev/sr0 as cdrom [solved]
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: permanent symlink created for /dev/sr0 as cdrom [solved]  (Read 2278 times)
Pardus Guru
Posts: 841

View Profile
« on: December 08, 2011, 03:07:42 AM »

After John A shared that Kscd would not play audio CD's automatically this thread,  I looked into this on my setup.  
The first problem I had was a homemade audio cd would not bring up kscd in the notifier applet as This cd disc had folders that contained music files, so notifier assumed it was 'data'. , I then finally (yes, I'm slow)  tried a retail commercial audio cd instead, and notifier popped up with 'play with kscd'.  Good!  But when the GUI would come up and I would click 'play' I would get a kdecrash handler report seg. fault.  I then found kde bug #222841 and installed phonon-xine-backend from package manager, replacing gstreamer backend,  and Kscd no longer crashed, but no sound.  
When I would give command
ls /dev/cdrom
it would say, not found.
I changed system settings>multimedia>specify CD Device: /dev/sr0, but I still got /dev/cdrom not found when trying to use command line to find it.

So I then tried the suggestion here to create a personal udev rule for my device.  Rebooted and now when I do:
ls /dev/cdrom
the output is in blue:
and Kscd now plays with sound.  I know I could use other players, but this is a native player since I like KDE I wanted to get it to play.  Oh, before getting it to work, I also installed kdemultimedia which installed Dragon Player, tunepimp, juk, thinking this would install some essential stuff for Kscd, but it did not help.  
Lisa Marie

« Last Edit: December 17, 2011, 21:18:13 PM by Lisa » Logged
« Reply #1 on: December 08, 2011, 15:20:29 PM »

hi lisa marie,
john a filed a bug report on the matter. it looks just a small bug to me, since the detection on connection seems to work ones kaffeine is installed.

but that looks a bit like a work around to me: yet another multimedia app.  Roll Eyes
Pardus Guru
Posts: 841

View Profile
« Reply #2 on: December 09, 2011, 00:48:21 AM »

Agreed. too much tweaking.  I put it all back to how it used to be and will use Deadbeef and Kaffeine. 
Pardus Guru
Posts: 841

View Profile
« Reply #3 on: December 09, 2011, 20:43:09 PM »

After looking at dmesg and /etc/udev/rules.d/70-persistent-cd.rules, I realize there is a problem, but I think it is hardware specific to my Lite-On LH-20A1S dvd rw. I am not going to file a bug report yet, because I remember reading a few years back about the Lite-On LH-20A1S having problems with booting from it when selected as first boot device in BIOS when one has two optical drives.  I never could get it to boot a live cd when on slave sata cable.  I've had plans on replacing it for a month now, just waiting for the right price.   I've already had to repair the strong magnet on it by dampening it with a piece of plastic (known product bug of not being able to eject disc).

Just to let you see what I am referring to, which doesn't look right:
# DVDRW_LH-20A1S (pci-0000:00:07.0-scsi-1:0:0:0)
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:07.0-scsi-1:0:0:0", SYMLINK+="cdrom", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:07.0-scsi-1:0:0:0", SYMLINK+="cdrw", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:07.0-scsi-1:0:0:0", SYMLINK+="dvd", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:07.0-scsi-1:0:0:0", SYMLINK+="dvdrw", ENV{GENERATED}="1"

# DRW-2014S1T (pci-0000:00:07.0-scsi-0:0:0:0)
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:07.0-scsi-0:0:0:0", SYMLINK+="cdrom1", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:07.0-scsi-0:0:0:0", SYMLINK+="cdrw1", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:07.0-scsi-0:0:0:0", SYMLINK+="dvd1", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:07.0-scsi-0:0:0:0", SYMLINK+="dvdrw1", ENV{GENERATED}="1"

And it gets even more confusing when in dmesg, Lite-On device is listed as
scsi 2:0:0:0: CD-ROM            LITE-ON  DVDRW LH-20A1S   9L09 PQ: 0 ANSI: 5
and my asus dvd rw is listed as:
scsi 3:0:0:0: CD-ROM            ASUS     DRW-2014S1T      1.01 PQ: 0 ANSI: 5

and this isn't right:
ls -l /dev/cdrom
lrwxrwxrwx 1 root root 3 Dec  9 03:29 /dev/cdrom -> sr1

Mandriva bug 36218 fits my problem.
Pardus Guru
Posts: 841

View Profile
« Reply #4 on: December 17, 2011, 21:17:17 PM »

Bought a new oem Hitachi/LG dvd burner sata connection from geeks dot com and installed it today.  This looks much better, so it was as I thought, problem related to that particular Lite On burner.
# DVDRAM_GH24NS50 (pci-0000:00:07.0-scsi-0:0:0:0)
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:07.0-scsi-0:0:0:0", SYMLINK+="cdrom", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:07.0-scsi-0:0:0:0", SYMLINK+="cdrw", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:07.0-scsi-0:0:0:0", SYMLINK+="dvd", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:07.0-scsi-0:0:0:0", SYMLINK+="dvdrw", ENV{GENERATED}="1"

# DRW-2014S1T (pci-0000:00:07.0-scsi-1:0:0:0)
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:07.0-scsi-1:0:0:0", SYMLINK+="cdrom1", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:07.0-scsi-1:0:0:0", SYMLINK+="cdrw1", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:07.0-scsi-1:0:0:0", SYMLINK+="dvd1", ENV{GENERATED}="1"
SUBSYSTEM=="block", ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:07.0-scsi-1:0:0:0", SYMLINK+="dvdrw1", ENV{GENERATED}="1"

ls -l /dev/cdrom/
shows sr0
« Last Edit: December 17, 2011, 21:19:10 PM by Lisa » Logged
« Reply #5 on: December 30, 2011, 08:10:28 AM »

although marked as solved, just a few bits to keep you amused  Grin

ones i've build my own pc from scratch. well, closer to the truth is i bought separate parts and assembled them to something that actually worked:
it could do neat things with bits, both with w95 and red hat 6.

one of the parts that needed special attention was strange enough the cd(!) player/burner. not very brand was suitable.
when i replaced the cd player a bit later with a dvd player/burner i had to try several brands in order to get it to work.

what i'm suggesting is that there are rather big differences in e.g. dvd devices, just like in hard disk drives (some get very warm and others are very noisy).
so, when replacing such a device, it's fairly important afaik, to take in consideration other parts of your pc, like motherboard and chipset(s).
some dvd devices even use jumbers and it's important to which cable it becomes connected, but you probably know these things already.

maybe you'll find some useful information on the website of the manufacturer of the used motherboard?

just the two bits from a lazy notebook user (would like to build an arm-based notebook though... Grin )
Pages: [1] Go Up Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!