Welcome, Guest. Please login or register.
April 19, 2014, 07:47:12 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Software
| | |-+  32-bit compatibility libraries for 64-bit Pardus?
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: 32-bit compatibility libraries for 64-bit Pardus?  (Read 1378 times)
Vakkotaur
Newbie
*
Posts: 13


View Profile
« on: February 02, 2012, 16:30:51 PM »

I've installed the 64-bit version of Pardus as I have 64-bit hardware.  For most software, this is fine.  Alas, there is no 64-bit version of Firestorm, the Second Life viewer (or any other Second Life viewer as far as I know) and I've been able to deal with this issue in other distributions by installing 32-bit compatibity libraries.  I've looked around in the Package Manager and not seen anything that appears to give 32-bit compatibility.  Am I missing something?  Or am I out of luck?
Logged
Anglo
Pardus Guru
****
Posts: 438



View Profile
« Reply #1 on: February 02, 2012, 16:45:23 PM »

Hi
Try this : https://parduswiki.pcdomain.com/Software
Logged
richdb
Administrator
Pardus Guru
*****
Gender: Male
Posts: 349



View Profile WWW
« Reply #2 on: February 02, 2012, 18:23:25 PM »

There are SL 64 bit party viewers, look here:

http://wiki.kokuaviewer.org/wiki/Downloads

And there viewers are based on java, so you can also try the x86 viewers.
Most of the time you only can have some media (video) problems.

Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #3 on: February 02, 2012, 19:28:21 PM »

Were can I find the package for Firestorm (i686 or x86_64)    or an url.
« Last Edit: February 02, 2012, 19:30:46 PM by atolboo » Logged
richdb
Administrator
Pardus Guru
*****
Gender: Male
Posts: 349



View Profile WWW
« Reply #4 on: February 02, 2012, 20:11:53 PM »

You can find them here:

http://www.phoenixviewer.com/downloads.php
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #5 on: February 02, 2012, 20:44:32 PM »

I am now busy building the PiSi packages for Bumblebee NVIDIA Optimus technology under Linux.
And maybe I will have a go at this one after I have finished.
A preview of the firestorm build and runtime deps.
They are apparently to lazy to make/issue a proper x86_64 version.
« Last Edit: February 02, 2012, 20:47:55 PM by atolboo » Logged
Vakkotaur
Newbie
*
Posts: 13


View Profile
« Reply #6 on: February 03, 2012, 08:09:45 AM »

As I understand it, they can build for 64, but choose not to as they have issue with the streaming audio.  This wouldn't bother me, personally, as I prefer to listen to any stream with another program and not fight the SL viewer over it.

I'll have a bit more to post later.  Thanks to Anglo, I installed the 32-bit compatibility stuff, but evidently Firestorm wants something not included there - or else wants something else that isn't a 32-bit issue but still is not around.  I'll be grabbing the output and uploading a file to be looked at in a few hours.
Logged
Vakkotaur
Newbie
*
Posts: 13


View Profile
« Reply #7 on: February 03, 2012, 11:22:58 AM »

When I try to run Firestorm, this happens:

http://www.conmicro.com/~vakko/pardus/firestorm_startuplog.txt

The first is the result of ./firestorm > firestorm_startuplog.txt  and the second block of text is what I get in terminal that didn't get sent to the file.  And yes, despite the warning text the 32-bit stuff is installed. I even did a complete just to be sure of things.
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!