Welcome, Guest. Please login or register.
April 19, 2014, 12:36:47 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  Updating libpng12-devel
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Updating libpng12-devel  (Read 1462 times)
Kranthi
Pardus fellow craft
**
Gender: Male
Posts: 102



View Profile WWW
« on: February 20, 2012, 07:10:44 AM »

Hi,
I was updating my system and I got this:

The following packages will be upgraded:
google-chrome  libbsd  libpng12  libpng12-devel                                                                                                                 
Total size of package(s): 35.93 MB
There are extra packages due to dependencies.
Do you want to continue? (yes/no)y                                                                                                                               
The following packages have conflicts:
[libpng12-devel conflicts with: libpng-devel ]

Remove the following conflicting packages? (yes/no)

The libpng12-devel package was downloaded from the devel repo for google voice and video chat. So I'll be still needing it. But I am wondering whether the libpng-devel is needed for any other program which would stop working once I upgrade the system. What should I do? Is there any way for me to know which files are dependent on the libpng-devel library?
Logged

The Cube
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #1 on: February 20, 2012, 19:27:56 PM »

A ...-devel package is needed when you want to compile software locally.
What are your repo's with the command
Code:
pisi lr
Huh?
Logged
Kranthi
Pardus fellow craft
**
Gender: Male
Posts: 102



View Profile WWW
« Reply #2 on: February 28, 2012, 06:13:29 AM »

My repos

pardus [active]
   http://packages.pardus.org.tr/pardus/2011/stable/i686/pisi-index.xml.xz
pardus user [active]
   http://pakete.pardususer.de/pardus-2011/i686/pisi-index.xml.xz
testing [inactive]
   http://paketler.pardus.org.tr/pardus/2011/testing/i686/pisi-index.xml.xz
devel [inactive]
   http://packages.pardus.org.tr/pardus/2011/devel/i686/pisi-index.xml.xz
googlecode [active]
   http://happy-kitty.googlecode.com/svn/trunk/pisi-index.xml.xz
arch [active]
   http://paketler.pardus-linux.org/P2011/i686/pisi-index.xml.xz
Logged

The Cube
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #3 on: February 28, 2012, 12:17:36 PM »

My current investigation shows that I can not find
The libpng12-devel package was downloaded from the devel repo for google voice and video chat.
this ^^^ package in  http://packages.pardus.org.tr/pardus/2011/devel/i686/

I can only find a libpng12-devel in http://paketler.pardus-linux.org/P2011/i686/
And a look of the files of both packages with the command
Code:
pisi info package-name -fs
shows that the common files are:
/usr/bin/libpng-config
/usr/include/png.h
/usr/include/pngconf.h
/usr/lib/pkgconfig/libpng.pc
/usr/share/man/man3/libpng.3
/usr/share/man/man3/libpngpf.3
/usr/share/man/man5/png.5

The strange behavior is that I can install both packages without any conflict reports.
And to make an estimation which -devel package is needed:
Where can I find the instructions for google voice and video chat Huh?
Logged
Kranthi
Pardus fellow craft
**
Gender: Male
Posts: 102



View Profile WWW
« Reply #4 on: March 03, 2012, 11:43:55 AM »

actually, I wanted to install "google voice and video chat" software. For which you, Atolboo, had guided me how to do that.
At that time i added the pardus-devel repository and downloaded the devel packages.
I disabled the pardus-devel repo after that.
This was where you had helped me install "google voice and video chat" software. (thanks again for that):
http://worldforum.pardus-linux.nl/index.php?topic=4214.0
So now i have the latest devel packages and i'm upgrading to the normal packages i think.
Or should i go ahead and install the newer packages and see if there would be any problem.
If I can revert back, I have no problem in ignoring the conflict.
Logged

The Cube
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #5 on: March 04, 2012, 17:35:34 PM »

This was where you had helped me install "google voice and video chat" software. (thanks again for that):
I guess I am getting er as I had forgotten about that.

My current advise is to remove libpng12-devel  as this package is only needed when building certain packages that have
Code:
        <BuildDependencies>
            <Dependency> libpng12-devel</Dependency>
in there pspec.xml file.
And then it's only needed at the moment when the building process is executed.
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!