Welcome, Guest. Please login or register.
April 21, 2014, 16:53:15 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Bugs
| | |-+  bangarang won't play dvd, looking for libavformat.so.52
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] 2 Go Down Print
Author Topic: bangarang won't play dvd, looking for libavformat.so.52  (Read 3026 times)
Lisa
Pardus Guru
****
Posts: 841



View Profile
« on: February 26, 2012, 19:30:46 PM »

Hi,
I installed Bangarang player from pardususer and it won't play movie DVD.  I tried in console,
Code:
bangarang play-dvd
bangarang play-dvd
Disc in /dev/sr0 is a Video DVD
Disc in /dev/sr0 is a Video DVD
Disc in /dev/sr0 is a Video DVD

then in bangarang gui clicked on medialists and clicked on the DVD:

Code:
libdvdread: Using libdvdcss version 1.2.10 for DVD access
libdvdnav: Using dvdnav version 4.1.4
libdvdread: Using libdvdcss version 1.2.10 for DVD access
libdvdnav: DVD Title: LIE_TO_ME_S1_D4
libdvdnav: DVD Serial Number: 3af0a108
libdvdnav: DVD Title (Alternative):
libdvdnav: Unable to find map file '/home/me/.dvdnav/LIE_TO_ME_S1_D4.map'
libdvdnav: DVD disk reports itself with Region mask 0x00f60000. Regions: 1 4

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient
and further down in console:
"GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstffmpeg.so': libavformat.so.52: cannot open shared object file: No such file or directory".  So, it is looking for libavformat.so.52, but there is only x.so and x.so.53 and x.so.53.31.100.
Lisa Marie
Logged
Anglo
Pardus Guru
****
Posts: 438



View Profile
« Reply #1 on: February 27, 2012, 05:02:41 AM »

Hi,
I installed Bangarang player from pardususer and it won't play movie DVD.  I tried in console,
Code:
bangarang play-dvd
bangarang play-dvd
Disc in /dev/sr0 is a Video DVD
Disc in /dev/sr0 is a Video DVD
Disc in /dev/sr0 is a Video DVD

then in bangarang gui clicked on medialists and clicked on the DVD:

Code:
libdvdread: Using libdvdcss version 1.2.10 for DVD access
libdvdnav: Using dvdnav version 4.1.4
libdvdread: Using libdvdcss version 1.2.10 for DVD access
libdvdnav: DVD Title: LIE_TO_ME_S1_D4
libdvdnav: DVD Serial Number: 3af0a108
libdvdnav: DVD Title (Alternative):
libdvdnav: Unable to find map file '/home/me/.dvdnav/LIE_TO_ME_S1_D4.map'
libdvdnav: DVD disk reports itself with Region mask 0x00f60000. Regions: 1 4

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient
and further down in console:
"GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstffmpeg.so': libavformat.so.52: cannot open shared object file: No such file or directory".  So, it is looking for libavformat.so.52, but there is only x.so and x.so.53 and x.so.53.31.100.
Lisa Marie


I see here : http://forum.ivorde.ro/ffmpeg-error-while-loading-shared-libraries-libavdevice-so-52-cannot-open-shared-object-file-no-t129.html (post 695 ) that you had done some updating ,
So I googled ffmpeg +  libavformat.so.52,, and here is one that I found interesting : http://forum.ivorde.ro/ffmpeg-error-while-loading-shared-libraries-libavdevice-so-52-cannot-open-shared-object-file-no-t129.html.
The only other thing I can think that may possibly help is to roll back the ffmpeg update.

anglo
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #2 on: February 27, 2012, 08:36:20 AM »

I will start working on this problem today within a few hours.
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #3 on: February 27, 2012, 14:40:41 PM »

Hi anglo and atolboo,
yes, I did think it was a matter of something needing catching up with another library, and no hurry on this, I just wanted to let pardususer folks know. 
Again, much obliged!
Lisa Marie
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #4 on: February 27, 2012, 15:07:40 PM »

Just to let you know about my progress.
Thanks to a.palius   there is now a new bangarang-2.1 (old=2.0.1)
This ^^^ is playing DVD on my test system.
The problem I have at this moment that although it's playing DVD, I still get the GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstffmpeg.so': libavformat.so.52: warning.
It's not an error but a warning.
And this warning prevents me from uploading this version to the pardususer.de repo at this moment.
At this moment I am trying to patch this version to prevent this warning.
Maybe this version is also designed to work with the old ffmpeg?
However the test version is now available at pardususer.de/my playground/bangarang
Maybe you are willing to test this one.
Logged
weird_tr
Pardus fellow craft
**
Posts: 73


View Profile
« Reply #5 on: February 27, 2012, 17:06:14 PM »

About the libavformat problem...

I was about to checkout xbmc, just for fun.. But got some errors, about a few missing libs. No problem, I did this:

Code:
pardus2011 lib # ln libavcodec.so.53 libavcodec.so.52
pardus2011 lib # ln libavformat.so.53 libavformat.so.52
pardus2011 lib # ln libavutil.so.51 libavutil.so.50
pardus2011 lib # ln libpostproc.so.52 libpostproc.so.51
pardus2011 lib # ln libswscale.so.2 libswscale.so.0

Now the errors got replaced by some new ones:

Code:
tris@pardus2011 ~ $ xbmc
/usr/lib/xbmc/xbmc.bin: /usr/lib/libpostproc.so.51: version `LIBPOSTPROC_51' not found (required by /usr/lib/xbmc/xbmc.bin)
/usr/lib/xbmc/xbmc.bin: /usr/lib/libavcodec.so.52: version `LIBAVCODEC_52' not found (required by /usr/lib/xbmc/xbmc.bin)
/usr/lib/xbmc/xbmc.bin: /usr/lib/libswscale.so.0: version `LIBSWSCALE_0' not found (required by /usr/lib/xbmc/xbmc.bin)
/usr/lib/xbmc/xbmc.bin: /usr/lib/libavformat.so.52: version `LIBAVFORMAT_52' not found (required by /usr/lib/xbmc/xbmc.bin)
/usr/lib/xbmc/xbmc.bin: /usr/lib/libavutil.so.50: version `LIBAVUTIL_50' not found (required by /usr/lib/xbmc/xbmc.bin)

It seems that libavxxxx is having some problems in Pardus.. Because a few months ago, I could easily run xbmc in pardus 2011 with no errors. Maybe its out of date?  Smiley

Greets,
Tristan
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #6 on: February 27, 2012, 22:00:55 PM »

About the libavformat problem...
And to reinstall the original ffmpeg (+ dep) do:
1.Get your hardware-platform with
Code:
uname -p
=xyz
2 Reinstall packages:
Code:
sudo pisi it http://packages.pardus.org.tr/pardus/2011/stable/xyz/x264-0.0_20110615-34-p11-xyz.pisi --reinstall -y
and
Code:
sudo pisi it http://packages.pardus.org.tr/pardus/2011/stable/xyz/ffmpeg-0.6.1_20110105-95-p11-xyz.pisi --reinstall -y
(replace xyz (2x in each command) with the result of "uname -p")
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #7 on: February 28, 2012, 03:59:41 AM »

Thank you!

I installed the test version you shared and now bangarang doesn't crash when I click on DVD from device notifier and it plays the video fine, but there is no sound.  I also notice that under audio settings (audio channel, equalizer) are grayed out where I can't access them, which probably has to do with why I am getting no sound from this player. 

I tried this version with both the recent ffmpeg version and also reverted back to the version of ffmpeg and x264 you suggested.  No difference.  I have gstreamer as phonon backend.
Lisa Marie

Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #8 on: February 28, 2012, 12:27:33 PM »

I tried this version with both the recent ffmpeg version and also reverted back to the version of ffmpeg and x264 you suggested.  No difference.  I have gstreamer as phonon backend.
Lisa Marie
Thanks for the feedback.
My current (rough) estimation is that it's not caused by ffmpeg.
And (a.palius and me) were already investigation this gstreamer issue .
(also an issue in the new Amarok-2.5.0)
To be continued.........
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #9 on: February 28, 2012, 15:05:52 PM »

Next day, so more time to play with bangarang and this time chose a video_ts folder under my Videos directory.  I right clicked on video_ts folder and "play with bangarang" and I get both video and audio with it, so that part is successful. 

I am now trying the another DVD disc with command line again, "bangarang play-dvd --debug" and no Warning is shown, still no audio, still no access to audio settings, but these lines are shown (probably has nothing to do with audio):

Using djbfft for IMDCT transform
QObject::connect: Cannot queue arguments of type 'MediaSource'
(Make sure 'MediaSource' is registered using qRegisterMetaType().)

and:

libdvdnav: Unable to find map file '/home/m5jg7asusa8ne/.dvdnav/JUPITER_MOON_D3a.map'
libdvdnav: DVD disk reports itself with Region mask 0x00c00000. Regions: 1 2 3 4 5 6


Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #10 on: February 28, 2012, 15:18:01 PM »

A few minutes later...
I have sound.
I didn't use device notifier to "play DVD with bangarang",
instead, I went to file manager, left pane, double clicked on JUPITER_MOON listing, and right clicked on video_ts folder, "open with bangarang" and now is picture and sound.
The only other thing is that audio settings remain inaccessible (grayed out).

As a side note, I have never been able to get sound from the Phonon Sound and Video Configuration GUI.  Clicking on Front Left and Front Right does nothing.  Maybe means something, maybe not.
Logged
weird_tr
Pardus fellow craft
**
Posts: 73


View Profile
« Reply #11 on: February 28, 2012, 15:58:53 PM »

Thank you Atolboo, that solved my problem  Wink
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #12 on: February 28, 2012, 16:11:50 PM »

Now two different problems are mixing.

@Lisa
The new bangarang-2.1-5  can play video and sound with the old/new ffmpeg.
And this playing sound depends on the contents of video files.
Is this a good conclusion Huh?
And do you get the same result when using f.i. VLC and/or SMPlayer as a video/sound player Huh?

@weird_tr
Where is this xbmc coming from Huh?
Maybe a rebuild against the new ffmpeg will solve the problem.
And to test this I need to find the build files of xbmc.
« Last Edit: February 28, 2012, 17:19:04 PM by atolboo » Logged
weird_tr
Pardus fellow craft
**
Posts: 73


View Profile
« Reply #13 on: February 28, 2012, 17:28:55 PM »

Atolboo, as I said before, your solution solved my problem ;p I can run XBMC now, but it crashes when i want to play a video Sad

I downloaded XBMC from Pisi.. And when i look it up, it comes from this scource:

Code:
http://paketler.pardus-linux.org/P2011/i686/pisi-index.xml.xz

When Xbmc crashes, it gives this error:

Code:
/usr/bin/xbmc: regel 133:  2293 Segmentatiefout         (geheugendump gemaakt) "$LIBDIR/xbmc/xbmc.bin" $SAVED_ARGS                                                         
Crash report available at /home/tris/xbmc_crashlog-20120228_153221.log   

The content of the log file is (where it went wrong):
Code:
14:32:18 T:2908564336 M:1196568576   DEBUG: DllAvUtilBase: Using libavutil system library
14:32:18 T:2908564336 M:1196568576   DEBUG: DllAvCodec: Using libavcodec system library
14:32:18 T:2908564336 M:1196568576   DEBUG: DllAvFormat: Using libavformat system library

Greets,
Tristan
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #14 on: February 28, 2012, 21:10:47 PM »

I downloaded XBMC from Pisi.. And when i look it up, it comes from this scource:

Code:
http://paketler.pardus-linux.org/P2011/i686/pisi-index.xml.xz
And as http://www.pardus-linux.org/ is all Turkish I don't think I will get any further.
There build files are not as accessible and transparent as they are at pardususer.de.
Logged
Pages: [1] 2 Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!