Welcome, Guest. Please login or register.
April 16, 2014, 18:15:20 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Pardus for beginners
| | |-+  Manual Time-Change Not Staying Permanent [SOLVED]
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Manual Time-Change Not Staying Permanent [SOLVED]  (Read 1157 times)
MusicLover
Pardus fellow craft
**
Posts: 90


View Profile
« on: March 29, 2012, 22:53:37 PM »

I've tried to adjust the time via the task bar (right-clicking etc) and via the settings page. When I restart the machine, the time goes one hour back.

Is there a command line way I can 'force' the time change?
« Last Edit: April 01, 2012, 14:53:31 PM by MusicLover » Logged
Anglo
Pardus Guru
****
Posts: 438



View Profile
« Reply #1 on: March 30, 2012, 02:16:03 AM »

Not sure of the command line method, but did you log on as root and go to start menu >settings>system settings>date and time ?
( assuming KDE ) ?
Logged
MusicLover
Pardus fellow craft
**
Posts: 90


View Profile
« Reply #2 on: March 30, 2012, 08:04:12 AM »

Not sure of the command line method, but did you log on as root and go to start menu >settings>system settings>date and time ?
( assuming KDE ) ?

The only logon I've got is the same one I used since installing Pardus so I'm sure I'm root.
Logged
Lisa
Pardus Guru
****
Posts: 841



View Profile
« Reply #3 on: March 30, 2012, 19:24:12 PM »

Hi,
When I've had problems with incorrect time is when I install another linux distro and suddenly my other distro's clock will show back or forward 4 hours.  I then have to reset my BIOS clock and all is well. 

You are doing it correctly, if it asks for your admin password when you hit 'apply' in the time/date GUI and then ok.  Wait one minute and the correct time will show in your toolbar clock.  I just tried mine out.  If I set the clock ahead an hour, it will also set my BIOS clock ahead an hour.  If I reset my BIOS clock to back to correct hour, it automatically resets Pardus os clock correctly.

Here are some command lines. but it has been a while since I've used them as I remember having problems understanding the difference between hardware clock and system time:

Code:
hwclock --help
or
Code:
date --help
there's also man pages for both, more detail information.

The following will show current date and time, as well as timezone:
Code:
sudo hwclock -r
Code:
date
Code:
timezone
Logged
atolboo
Pardus Guru
****
Posts: 2317



View Profile
« Reply #4 on: March 31, 2012, 13:39:51 PM »

Maybe the solution is in this Wiki > Automatic synchronization of date and time after every reboot Huh?
Logged
MusicLover
Pardus fellow craft
**
Posts: 90


View Profile
« Reply #5 on: April 01, 2012, 14:52:58 PM »

That seemed to do the trick!

Thanks.
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!