Welcome, Guest. Please login or register.
April 20, 2014, 19:40:28 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  Share directories via NFS
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Share directories via NFS  (Read 1358 times)
Leen
Guest
« on: February 27, 2007, 23:00:28 PM »

I try to share directories via NFS, but did'nt succeed completely:

My LAN:
Desktop (alias: scaleo)
   sda1   Windows XP   ntfs
   sda5   transfer   vfat  (to be shared)
   sda6   swap
   sda7   Pardus      ext3

Notebook (alias: asterix)
   hda1   Pardus      ext3

Both connected to a Belkin ADSL Modem with Wireless-G Router.
Scaleo is hard wired.
Asterix is wireless via a Belkin F5D7010df WiFi-card.
The PC's can "ping" each other.

To set up NFS.
Scaleo is the NFS-server:
Pardus -> Tasma -> System -> Service Manager
   select NFS Daemon
   activate: Run on Startup
Edit /etc/exports:
   /mnt/sda5  asterix(async,no_subtree_check,rw)
Create /etc/hosts.allow:
   # Portmapper is used for all RPC services; protect your NFS!
   # (IP addresses rather than hostnames "MUST" be used here)
   # the address for asterix is 192.168.2.3
   portmap: 192.168.2.3
   lockd: 192.168.2.3
   rquotad: 192.168.2.3
   mountd: 192.168.2.3
   statd: 192.168.2.3

Asterix is the client:
Pardus -> Tasma -> System -> Service Manager
   select Portmap
   activate: Run on Startup
Create a mountpoint:
   # mkdir /media/sda5
Edit /etc/fstab; add:
   scaleo:/mnt/sda5  /media/sda5  nfs  rw,hard,intr  0  0

Now my problem:
When asterix has booted there is an icon on the desktop
"Remote Share (scaleo)"
When I click on that icon I got an error: "Permissions denied"
If (as root) I mount the share manualy:
# mount scaleo:/mnt/sda5 /media/sda5
and then click the icon I have access to the share.

What do I need to do to automount the share ?

Regards,  Leen
Logged
Joe90
Newbie
*
Posts: 5


View Profile
« Reply #1 on: March 25, 2007, 23:45:50 PM »

Me too. I get to the same point on the client side. Can manually mount no problem, but the on start up option in fstab produces the permission denied dialog.
Logged

xperience Is The Only Genuine Knowledge
roverrat
Pardus Master
***
Posts: 236



View Profile
« Reply #2 on: March 31, 2007, 19:24:15 PM »

Have you tried adding the option "user" to the entry in /etc/fstab?
This will allow ordinary users to mount the share. (Normally only root will be able to do this)
Logged
Leen
Guest
« Reply #3 on: March 31, 2007, 21:07:31 PM »

Indeed, I changed  /etc/fstab to:

[/code]
scaleo:/mnt/sda5  /media/sda5  nfs  users,rw,hard,intr  0  0
Code:


and as user I can mount the share.

Regards,  Leen
Logged
Leen
Guest
« Reply #4 on: March 31, 2007, 21:08:37 PM »

Oops, something wrong with [code]
sorry
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!