Welcome, Guest. Please login or register.
April 24, 2014, 10:39:48 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Software
| | |-+  OpenOffice Spellcheck
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: OpenOffice Spellcheck  (Read 2332 times)
RDNZL
Newbie
*
Posts: 22


View Profile
« on: March 24, 2007, 09:36:33 AM »

Hi there,

When I activate 'spell check when you type' nothing happens: no red underlined words appeared - even when I make mistakes.

When I activate 'spell check' (with F7 key) spell checking opens and quits again immediately stating: 'Spell checking completed'.

How come?

Thanks!
Logged
Tiedemann
Newbie
*
Posts: 17


View Profile
« Reply #1 on: March 24, 2007, 19:37:57 PM »

Quote from: "RDNZL"
Hi there,

When I activate 'spell check when you type' nothing happens: no red underlined words appeared - even when I make mistakes.

When I activate 'spell check' (with F7 key) spell checking opens and quits again immediately stating: 'Spell checking completed'.

How come?

Thanks!


You'll need to install the "openoffice-dicts" package.
Logged
RDNZL
Newbie
*
Posts: 22


View Profile
« Reply #2 on: March 25, 2007, 12:16:03 PM »

Thanks for your reply!

Where can I get this 'openoffice-dicts' package?

I have no internet connection so I have to download it manually, via my Apple iMac, put it on a USB stick, transfer it to Pardus, etc. :? :? :?
Logged
RDNZL
Newbie
*
Posts: 22


View Profile
« Reply #3 on: March 25, 2007, 13:06:16 PM »

I've got the answer already!

Found the dictionaries.pisi and the help.pisi I believe on the Pardus FTP, downloaded, put them on the USB stick, moved them to the desktop in Pardus, installed manually via the terminal, both works like a charm!
Logged
Tiedemann
Newbie
*
Posts: 17


View Profile
« Reply #4 on: March 25, 2007, 14:46:21 PM »

Quote from: "RDNZL"
I've got the answer already!

Found the dictionaries.pisi and the help.pisi I believe on the Pardus FTP, downloaded, put them on the USB stick, moved them to the desktop in Pardus, installed manually via the terminal, both works like a charm!


OpenOffice language packs are also compatible with Thunderbird and Firefox, and can be used to add dictionary support for languages not otherwise supported by Mozilla.

The relevant spelling dictionary can be downloaded from http://wiki.services.openoffice.org/wiki/Dictionaries, unzipped, and the .aff and .dic files copied to /usr/lib/MozillaThunderbird/components/myspell/ or usr/lib/MozillaFirefox/dictionaries/
Logged
RDNZL
Newbie
*
Posts: 22


View Profile
« Reply #5 on: March 26, 2007, 08:45:21 AM »

Will it work for 'OpenOffice' when copied to the Mozilla folder?

I have found dictionaries indeed in the folder you indicated but thought they were used by Mozilla or something.
Logged
Tiedemann
Newbie
*
Posts: 17


View Profile
« Reply #6 on: March 26, 2007, 14:35:34 PM »

Quote from: "RDNZL"
Will it work for 'OpenOffice' when copied to the Mozilla folder?

No, you need to copy them to /opt/OpenOffice.org/lib/ooo-2.1/share/dict/ooo

There's a guide to manually installing OpenOffice dictionaries here.

Incidentally, adding .aff and .dic files to /usr/lib/MozillaThunderbird/components/myspell/ is currently the only way of adding dictionaries to Thunderbird (adding one via an .xpi file doesn't work).
Logged
RDNZL
Newbie
*
Posts: 22


View Profile
« Reply #7 on: March 26, 2007, 15:57:56 PM »

Oh, okay, I understand.

Thanks!
Logged
joske
Pardus fellow craft
**
Posts: 49


View Profile WWW
« Reply #8 on: March 26, 2007, 16:43:10 PM »

I have a stupid question: how to change the language of the text in an OpenOffice document? (For example the default is English, but I want to set all text as Dutch)

I can't find where to do that..
Logged
Tiedemann
Newbie
*
Posts: 17


View Profile
« Reply #9 on: March 26, 2007, 21:10:29 PM »

Quote from: "joske"
I have a stupid question: how to change the language of the text in an OpenOffice document? (For example the default is English, but I want to set all text as Dutch)

I can't find where to do that..

Tools > Options > Language Settings > Languages > Default languages for documents
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!