Welcome, Guest. Please login or register.
April 18, 2014, 10:52:03 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  Installing modules at start up, Persistent NFS shares
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Installing modules at start up, Persistent NFS shares  (Read 1679 times)
Joe90
Newbie
*
Posts: 5


View Profile
« on: March 24, 2007, 16:22:59 PM »

Hi

Am majorly impressed with the out of the box experience with Pardus, but am having a couple of problems.

ASUSTEK P7131 DVB/Analogue Hybrid TV card

It works OK, and I can load the required modules manually, but cannot figure out how to get them to load at start up.

To get the card running I need the following:

Code:
sudo /sbin/modprobe saa7134 card=78 tuner=54
sudo /sbin/modprobe saa7134-dvb


I have a feeling that the saa7134 module might already be loading, hence the options I need cannot be loaded "again".

Persistent NFS shares

I have an NFS server on my LAN at 10.10.10.70

I can manually mount as follows:
Code:
sudo mount 10.10.10.70:/media/music /media/music

but this doesn't persist through a reboot. I have ticked all the settings I can find but no go. Great that NFS client is there as default.
Logged

xperience Is The Only Genuine Knowledge
Jan Gnodde
Global Moderator
Pardus Guru
*****
Gender: Male
Posts: 397


View Profile WWW
« Reply #1 on: March 25, 2007, 08:33:04 AM »

You can put your commands in the file /etc/conf.d/local.start

Jan.
Logged
Joe90
Newbie
*
Posts: 5


View Profile
« Reply #2 on: March 25, 2007, 14:21:51 PM »

Quote from: "gnodde"
You can put your commands in the file /etc/conf.d/local.start

Jan.


Thanks Jan, but that didn't work - these are modules rather than programs?

Now find I need to get ndiswrapper runing at start up too. The command "ndiswrapper -m" which creates an alias, doesn't have the desired impact, so i am also having to run:
Code:
sudo /sbin/modprobe ndiswrapper


I know this is a simple one, Ubuntu points you to a modules file, but this doesn't seem to be available/or work (if created) under Pardus)
Logged

xperience Is The Only Genuine Knowledge
Jan Gnodde
Global Moderator
Pardus Guru
*****
Gender: Male
Posts: 397


View Profile WWW
« Reply #3 on: March 25, 2007, 16:14:57 PM »

Take a look at /etc/modules.autoload.d/kernel-2.6

And, for ndiswrapper, maybe a look at http://worldforum.pardus-linux.nl/viewtopic.php?t=34 will help.

Jan.
Logged
Joe90
Newbie
*
Posts: 5


View Profile
« Reply #4 on: March 25, 2007, 19:05:50 PM »

Hi Jan

yes, I started with that kernel2.6 file, and followed the ndiswrapper post. They didn't work last time, but I'll try them again and report back.... :shock:
Logged

xperience Is The Only Genuine Knowledge
Joe90
Newbie
*
Posts: 5


View Profile
« Reply #5 on: March 25, 2007, 23:20:19 PM »

Ok

/etc/modules.autoload.d/kernel-2.6

Is the place, ndiswrapper loaded just fine.

saa7134 with options doesn't load. i think it is already loading further up the chain, as I have to rmmod it before i can load it with the options when the desktop is up.

How do I stop it loading in the first place?
Logged

xperience Is The Only Genuine Knowledge
roverrat
Pardus Master
***
Posts: 236



View Profile
« Reply #6 on: April 16, 2007, 17:48:35 PM »

As for the persistent NFS shares, you can mount them through /etc/fstab.
Try putting the following line of code in this file:

10.10.10.70:/media/music /media/music nfs defaults 0 0
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!