Welcome, Guest. Please login or register.
April 20, 2014, 19:36:12 PM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Bugs
| | |-+  K3B disables DMA of Burners
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: K3B disables DMA of Burners  (Read 2416 times)
diskmusic
Pardus fellow craft
**
Posts: 69



View Profile
« on: April 09, 2007, 06:03:17 AM »

When I start up K3B, it somehow disables DMA and then complains that the drive doesn't have DMA support enabled.

I know how to use the root and can enable DMA through
"hdparm -d 1 /dev/hd(x).

Quote from: "http://k3b.plainblack.com/faq"
Q: My DVD drive supports 16X but K3B keeps burning at 1X! What's happening?
A: Your kernel most likely didn't apply optimal settings for your drive when it detected it. You can find out what are the current settings of your drive with the command

hdparm -v /dev/dvd

/dev/dvd:
 IO_support   =  0 (default 16-bit)
 unmaskirq    =  0 (off)
 using_dma    =  0 (off)
 keepsettings =  0 (off)
 readonly     =  0 (off)
 readahead    = 256 (on)

The following options are known to maximize burning and playback performance:

hdparm -d1 -c1 -a8 -u1 /dev/dvd

To make these options permanent, a quick and dirty solution is to include the command in /etc/rc.local. Consult your distribution documentation for a tailored solution.
Some drives have buggy DMA support. If you experience instability, leave these options disabled.
Some useful references:
http://www.togaware.com/linux/survivor/CD_DVD_Drives.shtml
http://www.linuxjournal.com/article/6921


Is there a command in Pardus, to set DMA permanent for optical drives?
Logged
Jan Gnodde
Global Moderator
Pardus Guru
*****
Gender: Male
Posts: 397


View Profile WWW
« Reply #1 on: April 09, 2007, 08:30:22 AM »

You can put your command in /etc/conf.d/local.start

Jan.
Logged
diskmusic
Pardus fellow craft
**
Posts: 69



View Profile
« Reply #2 on: April 09, 2007, 09:52:12 AM »

Ciao Jan,

found a report (Id=5380) on BugZilla, date 31-3-2007

Maybe it is easy, but what am I suppose to write in that file after I open the console>su>password>kwrite>open location etc/config.d/local.start.

Quote from: "etc/config.d/local.start"
# /etc/conf.d/local.start

# This is a good place to load any misc programs
# on startup ( use 1>&2 to hide output)
      



Greetz ..  Cool
Logged
Jan Gnodde
Global Moderator
Pardus Guru
*****
Gender: Male
Posts: 397


View Profile WWW
« Reply #3 on: April 09, 2007, 11:32:21 AM »

Below those lines (they do nothing, because they're commented out by the "#"-signs) you can put:
Code:
hdparm -d 1 /dev/hd(x)

or any command you wish to execute at start-up.

Jan.
Logged
diskmusic
Pardus fellow craft
**
Posts: 69



View Profile
« Reply #4 on: April 09, 2007, 19:04:49 PM »

I will try! Thanks for your help Cool
Logged
diskmusic
Pardus fellow craft
**
Posts: 69



View Profile
« Reply #5 on: April 10, 2007, 00:25:22 AM »

Problem remains, have to restart in root DMA after each burn! Cool
Logged
jnmbk
Pardus Developer
Pardus Master
*****
Posts: 174


View Profile
« Reply #6 on: April 11, 2007, 10:37:48 AM »

That seems to be a common bug:
https://bugs.launchpad.net/ubuntu/+source/k3b/+bug/102316
Logged
diskmusic
Pardus fellow craft
**
Posts: 69



View Profile
« Reply #7 on: April 11, 2007, 22:38:10 PM »

It would be great if it could be fixed!
I understand that this bug runs through different versions of linux.
You could state that it is a bug to be addressed by the developers of K3B, my concern though is that it could turn away potential users who lack the skill to use the console. Or simply do not want to have the hassle to enable DMA by hand!
Knowing that Pardus comes with K3B gives although it could be discussed as unfair pressure to fix a problem created by K3B.

Greetz .. Dis Cool
Logged
diskmusic
Pardus fellow craft
**
Posts: 69



View Profile
« Reply #8 on: April 20, 2007, 06:09:27 AM »

DMA bug is fixed by Sebastian Trueg in cooperation with Antoon Tolboom. Cool
Used there method of applying a patch to K3B and am running haply in DMA mode after verifying a burned disk Cool
Logged
mehmet75
Guest
« Reply #9 on: June 22, 2007, 19:16:49 PM »

you can try this solution. You will add "combined_mode=libata" at the end of kernel line. Example:

title Pardus 2007.1 [2.6.18.8-83]
root (hd0,2)
kernel (hd0,2)/boot/kernel-2.6.18.8-83 root=/dev/sda3  video=vesafb:nomtrr,pmipal,ywrap,1024x768-32@60 splash=silent,fadein,theme:pardus console=tty2 mudur=language:tr quiet resume=/dev/sda8 combined_mode=libata
initrd (hd0,2)/boot/initramfs-2.6.18.8-83
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!