Welcome, Guest. Please login or register.
April 20, 2014, 06:51:24 AM
Home Help Search Calendar Login Register
Show unread posts since last visit.
News: Let Pardus-Anka become #1: Pardus-Anka Bug ReportPardus-Anka World Google+ | The Pardus wiki  | Visit Pardus-Anka official website  | Register as forum member?  Email the moderator!

+  Pardus Worldforum
|-+  Assistance
| |-+  Configuring Pardus
| | |-+  [solved]dell 1390 wlan card
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: [solved]dell 1390 wlan card  (Read 1082 times)
« on: April 23, 2007, 07:08:14 AM »

I have spent days reading all the posts on this forum about how to configure a wireless card. Nothing has worked. Hopefully someone can help me.

I have a HP notebook with dell 1390 wireless card. Configuring the card according to posts on this site has marginal success. The adapter card light turned from orange to blue. So guess some success.

When I create access point in network manager I get an error message that says can't authenticate. I found a posting on this forum that talked about how to make wpapsk work. But it did not for me.

Can anyone help?

Also a couple of questions?
1. How do you restart network in Pardus? Can't find command.
2. I would like to setup my nics from the command line and add a eth0:0 interface. Where do I find the configuration files?

Some pointers would be greatly appreciated.

« Last Edit: July 09, 2008, 12:22:33 PM by Andreas » Logged
« Reply #1 on: April 23, 2007, 21:39:02 PM »

Okay, its now solved. I am conflicted with being happy that I have it working to being irritated that it took several days to figure it out.

Here is my hardware specs and steps to get it working:

HP Pavilion dv6253cl 64AMD
Nvidia GeoForce Go 6150 graphics
 /Dell 1390 WLAN Mini-PCI Card - Broadcom Corporation (wlan0)

1. Downloaded http://h10025.www1.hp.com/ewfrf/wc/softwareDownloadIndex?softwareitem=ob-45290-1&lc=en&cc=us&dlc=en&product=3231998&os=228&lang=en

This was the only driver I could find that would work.

2. Did  the following commands:
#ndiswrapper -l
This ensures that no other drivers are installed. If the command returns a driver use ndiswrapper -r driver and remove.

3. I used wine to extract the fireware but any tool that extracts will do.
#wine sp34152.exe
This installs the driver to /root/.wine/drive_c/SWSETUP

4. I then selected SP34152 directory
5. Then selected bcmwl5.inf driver
6. #ndiswrapper -i bcmwl5.inf
7. ndiswrapper -l  (to see if driver installed) should see driver
8. modprobe ndiswrapper
9. At this stage card is activated but not working
10. I then went to /etc/conf.d/wpa_supplicant file and inserted the following info:
      #Only WPA-PSK is used.
         psk=your security passphrase here
Save and exit

11. Opened network-manager and entered in ssid, autmode, secret key, and selected scan. It found the access point and I selected it and exited.

12. Then typed:
#wpa_supplicant -Dndiswrapper -iwlan0 -c/etc/conf.d/wpa_supplicant

13. Selected wireless connection in network-manager and had connection.

Everything worked. Please understand I have no clue to what I am doing but now it works. If this helps someone else figure it out and not spend days trying then I've accomplished something.
Pages: [1] Go Up Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!